Stuck with 2g after reinserting the simcard

Problem: My Xperia10 and new Xperia10-3 are both stuck with 2G on the same simcard. Mobile internet does not work at all.

So what happened:
i had X10 (latest with a KPN simcard. Mobile internet working just fine, using it as my main phone.
I bought a new X10-3 to install SF on it. So first i took out simcard from X10 and put it into X10-3 to check everything is working fine on android (before installing SF). And it was working perfectly fine.
Then i took out the simcard again and put it back into X10. At this point (after restart) it was stuck with 2G and mobile internet not working at all (can make calls though). No amount of restart changed anything.
Then i proceed with installing SF on X10-3. Everything went smoothly, no errors. SF works fine. I put the simcard in it, and it works just fine with 4G.
Then i wanted to put an sdcard in it, so naturally had to took out the simcard. And after putting it back, it is showing 2G, basically same as X10.

And that’s it. Tried putting simcard back and forth into both phones, multiple restarts. And both only show 2G. Checked the simcard with another android phone, and 4G is working fine, so simcard seems alright.

Wifi is working just fine and overall both phones run smoothly.

My experience is similar with my Xperia 10 after updating SF to In my old Xperia X the simcard has no problem connecting 4G. But my Xperia 10 (single sim)with this same KPN simcard is stuck on 2G.

What’s KPN?

Anyhow, have you checked the Settings => Mobile network => Network Mode?

If that doesn’t help, it could also be the provider making you suffer because you rapidly change their SIM card between phones, cheeky cheeky.

KPN is mobile operator in EU

i tried few things already suggested in other threads. There are, it seams, quite few issues with mobile internet in last release reported by some people.
It is not simcard related, since it’s working fine on android phone.