Stuck in EULA agreement loop, trying to reflash

REPRODUCIBILITY (% or how often): N/A
BUILD ID = OS VERSION (Settings > About product): Can’t access it anymore
HARDWARE (XA2, X10, X10 II, …): XA2 Ultra
REGRESSION: (compared to previous public release: Yes, No, ?): no idea


After selecting Finnish installation language, the OS asks to accept to EULA. Clicking accept results in a loading screen, which returns to the “Hej, Hallo, Terve, Moi, Holla, Privet, Guten Tag” or whatever screen. This can be repeated infinitely many times.

Currently trying to reflash with on linux/fastboot-31.0.2 resulted in a bunch of remote: unknown command errors, or “FAILED (Write to device failed (Cannot send after transport endpoint shutdown))” - this one also causes the phone to reboot (could be the other way around too, hard to tell). Sometimes even the “getvar” command results in this error message, which makes completely unusable.

I even tried to reflash Android with Sony Emma, but that too fails, and now I can’t boot to even the broken EULA screen. What can I possibly do anymore, when almost all fastboot commands fail? (*NOTE: this was already the case before the failed Emma effort).

Sometimes when I spam a getvar command, it works (as in, returns a value) every second time, and every second time there’s an “unknown command” error. Some very strange stuff is happening here…

Tips are appreciated.

Managed to flash XPERIA Android 8 rom with Emma, but fastboot commands still fail – issuing any of the fastboot commands causes a USB disconnect to occur and the command to fail.

MY GOODNESS. It turns out that some devices can’t handle fastboot commands coming from USB 3.0 ports:

Using a USB 2.0 port made everything work just fine.


Yeah. Known issue. Unfortunately.