Sony Xperia XA2 Ultra, single SIM (H3213, H3223) flash.sh syntax error

Hello everyone,

I am using a mac with macOS BigSur version 11.6.5 and trying to flash a Sony Xperia XA2 Ultra. I am getting the following error message:

Flash utility v1.2

Detected Mac OS X - Version: 11-6

Searching device to flash…

Found H3213, serial:CQ3000BLMP, baseband:1311-2927_50.2.A.3.77, bootloader:1310-0301_X_Boot_SDM630_LA3.0_P_38

Found matching device with serial CQ3000BLMP

Fastboot command: fastboot -s CQ3000BLMP

flash.sh: line 434: syntax error near unexpected token `<’

flash.sh: line 434: ` done < <(find “$b_path” -maxdepth 1 -name “$image_file” -print0)’

Does anyone have any clues for solving this issue?
Thank you a lot and best wishes
Chris

Are you using zsh or bash in terminal as pointing out a syntax error in this particular line?

I am using bash. Could this already be the issue? Suggest I try zsh?

ok. tried zsh and got the same error message…
Thank u a lot!

by the way, the mentioned line in flash.sh looks like this:
done < <(find “$b_path” -maxdepth 1 -name “$image_file” -print0)
not sure if this is correct. Anyhow, when I tried to make some changes and run flash.sh again I get a md5-cheksum error message and being told to download again. Is there a way to edit flash.sh and still use it?

Thanks and best
Chris

The scheme

while read thing
    do something
done <  <( list command )

is correct and valid as long as:

  • the shell recognizes the <(list command) construct as input file to read from. (It basically means “produce a list of things using list command, and pipe it into the while...done loop as if it were a file with the list as content”).
  • list command actually produces some output, i.e. does not throw an error.

I think this is happening when there is no image file in the directory you execute the flash script from
should be executed like ./flash.sh

Read the manual you need the base image from Sony