Sony Xperia III - Android 12

Thanks for these replies! Tried it and most things went fine. I though had several “WTF” moments:

  • Flashing went fine. When I unplugged the cable the blue LED stayed on and pressing the power button seemed to have no effect. In the end I connected it again to USB and rebooted using fastboot reboot. That worked well. :relieved:

  • When I aborted the tutorial (long time SailfishOS user; since the Jolla 1), it suddenly no more accepted any gestures and the LED went red. It vibrated when it recognised my finger, but that’s all it did in that state. I managed to turn it and reboot of by pressing the power key for quite a while. :face_with_raised_eyebrow:

  • It then asked the PIN twice and the first time the vibration upon typing did not work (but also didn’t look like the normal SailfishOS login). It though seems to do that now with every boot. My XA2 did not do that, even not with the same version ( of SailfishOS. (Although I’m not sure how often I rebooted with that version.)

  • When restoring the backup from my XA2 from a microSD card it at the end stated (in German): “Error: Couldn’t load notes” with a √ behind. And indeed, the Notes application is empty. But not only the notes are missing, also all contacts and calendar entries, i.e. the most important stuff. :angry:

    This first looked like Manual backup to SD: failure to load playlists or notes but that seems about the actual backup failing, while for me the restore is failing.

Not sure if issues or if that’s “just as it is”:

  • The “Network mode” switch only offers 4G, not 5G. I’m not sure if there should be 5G support or not. Android definitely did work with 5G. :disappointed:

Probably “just as it is” and unrelated to any Android version:

  • The backup also didn’t seem to restore any UI settings or similar. (Never tried a restore before though.), but IIRC that never worked. Maybe also related to not having finished restoring the backup. :slightly_frowning_face:

Anyway, otherwise seems to work fine. Didn’t have a phone call yet (just a missed call :upside_down_face:), though.

1 Like

But according to Jolla documentation (, 62.0.A.3.109 should be fine, right? Or am I missing something? Emma gives me the option to flash to 62.0.A.3.17 or 62.0.A.3.109. No 61 versions appear, nor *.9.11.

How do I relock the bootloader, btw?


1 Like

Emma doesn’t show the latest update, but I guess something similar to a stop release? You get the latest updates from within android as an OTA update.

To relock the bootloader simply fastboot oem lock.

1 Like

Yup, same here. WTF, Jolla? This is indeed a dealbreaker, when the backup cannot restore the phonebook on another device!

Btw: I flashed SFOS onto the device when it ran Android 11.


This may help :slight_smile:


Thank you!!

I reflashed following your sequence and the screen wake-up problem ([] XPERIA 10 III - Screen wakes up for no reason -> Battery drainage - #7 by nephros) appears to be gone.

Apparently, selecting the proper Android 11 version from which to install SFOSX is a big deal.

1 Like

hi folks, I am stuck on connecting Xperia 10 III to windows 10 laptop. Emma doesn’t see the device. Also fastboot devices command in DOS returns empty. seems I am missing the right driver, but Windows says latest android usb is installed, also I installed Sony;s xperia drivers sa0114adb.inf from sony site. Tried USB 2 and USB 3 ports. still phone is not visible by windows. The sequence of the steps and software versions ?

Guys does anybody know any tips on how to keep volume up button pressed plus plug in the USB cable end into Xperia 10III at the same time in order to get a blue light? because I am always getting red light and never blue. (USB debugging and developer options are on. wifi is on) thanks.

It starts with red light and then turns blue few seconds later if you had the up volume button pressed while plugging usb in, so red light does not mean it went wrong, maybe this is what’s happening?

Thank you for reply! yes, I had it turn blue (first red and then soon blue) twice out of about 50+ attempts on connection. On a second time I managed to unlock bootloader successfully, but did not have a chance to Emma down the android version from 12 to 11, and now I can no longer get it blue to complete the process of android downgrading with Emma. It never turns blue again (another series of about 20+ attempts). It might be that I got a defective unit in this particular functionality. ?

For Emma you need to put the phone into bootloader mode not fastboot. Turn the phone completly off, holf Volume down and insert the USB cable, the light should turn green or first red then green.

super, thank you! That was not clear from the doc. will get it going.

one more time thanks for help, guys! Here is the main tip which was my show stopper with getting blue dot (or green dot for that matter).
Hold the Volume UP button and simulatinustly insert the USB cable other end into the phone. Do not release the button!
Keep holding it, until the light turns on Blue! I was releasing it as soon as cable got connected solid. go figure. +))

1 Like

forgot to mention, driver. On windows 10 Pro 64bit (dell laptop) latest and greatest as of today, I used this new sony driver:
instead of recommended by Jolla sa0114 (which did not work).

well … some weeks ago I finally got this phone AND a charger - unfortunately it is using Android 12 already and “Emma” tells me the device is locked, even though I unlocked it … Could anyone of you sit down together with me so that we can make it work? … this is the first time I’ve ever done anything like that and I am sorry but I don’t understand why even when unlocking it I still get the message that it’s locked … do I need to insert the SIM-card in both slots and try unlocking it twice? … it’d also be helpful maybe if we could do this in real-time maybe … via a conversation or call with “Discord” maybe? … Can you please help me? Thank you!

tried unlocking via this

phone is locked

How did you “unlock” it?

Are you getting the warning message about unlocked bootloader at power up?

@jameson and @nephros

I used this here to unlock my phone … I get the error message after booting the phone while holding the VOL- and plugging in the USB cable

EDIT: Sorry, I was confused. Thanks @jameson for pointing out my mistake.

For Emma you need to hold Volume-Up and power.
For flashing (fastboot) it’s Volume-Down and power.

Not quite, it’s the other way around.