Sony Xperia 10 II bootloader unlock fails

Hello ,

like many others I stuck with unlocking my phone. Following the procedure which Jolla gave, my journey derailed after:

7.12 Enter the following command into the Windows terminal app (see 7.13 for an example about the actual command):
fastboot oem unlock 0x[inserting my received unlock code]

to

FAILED (remote: ‘unknown command’)
fastboot: error: Command failed

instead of
OKAY [ 1.716s] finished. total time: 1.720s

My upfront check for an unlockable bootloader said yes. The Developer options and USB debugging have been enabled whilst connected to an mobile network. Fastboot-Driver is installed as described and apparently working. The command fastboot getvar all prompts all the device related data. (e.g.: product:XQ-AU52, (bootloader) unlocked:no, (bootloader) secure:yes)

I tried two different cables (one being the original Sony one) on two different computers (Win 10 with latest updates & Ubuntu 20.04) on all their USB ports. I used different versions of fastboot on Windows. I restarted the computer and the phone several times.

Trying and googling for five hours hasn’t brought any changes nor given any further ideas.
I remember it was already a f@#µng hassle on my Xperia X, but it finally worked. But this time I have to surrender and accept that I’m not computer savvy enough to install SFOS again.

My conclusion/advice is that it is better trying to install SFOS (free version) on a new phone first and then buy the license! Don’t be as dumb as I was :cry:

Presumably you came across this Jolla resource in your travels which goes a bit deeper?
https://jolla.zendesk.com/hc/en-us/articles/115003840273#Windows

1 Like

Ciao!
I left the parentheses away:

fastboot oem unlock 0x your number

I got the equal warning …fastboot error. But then succeeded in.

It might be no fault of yours at all.
Many USB3 connectors just doesn’t work because the bootloader and fastboot application goes out of sync somehow.

TL;DR Try another port, preferably USB2, or a USB2 hub.

3 Likes

Thanks for the link. My search didn’t hit this page, but many advices there I found likewise elsewhere. But nevertheless that’s a comprehensive, detailed and helpful tutorial.
But in the end I don’t have a clue what layer from 1 to 8 bears the solution. Everything is just random trial and error (which I’m feed up of).

Thanks for your moral support.
Like I said to @aspergerguy I don’t have a clue what layer from 1 to 8 bears the solution. Everything is just random trial and error. Feel like wasting my time.

Sure, the parentheses aren’t needed for the command. After a perceived 100 times of sending this very command with still no success I was about to rampage.

It definitely sounds like you have everything set up correctly.
If a simple fastboot getvar product only works intermittently, you are hit by the issue i mentioned.

Ooh. I’m sorry. Strange. I did not follow Jolla instructions for unlocking. If I remember, I installed Android tools or something.
from the net. I loaded the instructions from net ‘how to unclock bootlockloader of Xperia 10 II’ As I always have done with Xperia X and XA2 earlier, after unclocking I returned to the Jolla instructions. Damn, I always do it but do not remember not anymore how.

fastboot getvar product worked always. That’s why I was pretty sure nothing’s wrong with my “physical & data layer”. As a family man I had to shrink my computer pool to two only. Also my still working USB C cables are limited. With kids the amount of misplaced things are incredible high. By luck I could get hold of two. Thus my possible USB-ports and cables variations are limited.
I was pretty sure my Linux box has USB-2 ports (may I should recheck later on this week). But as I said this whole thing is like fishing in murky water.

I succeeded in bootlockloader unlocking with these:

https://developer.sony.com/develop/open-devices/get-started/unlock-bootloader/how-to-unlock-bootloader/

No problems. I do not know any usb problems. Just did it.

One thing that worked for me was switching cords. I had a pretty long one, and switched to a different one and it worked instantly.