Some way to render a qml page without compiling and installing an app?


I’m trying to work on dessigning the UI of the page, and between I don’t know a lot qt5, and the process of compiling and installing the app, to see the output I’m loosing a huge amount of time. There is some way to dessign and test a screen maybe with mocked texts and mocked data, to test and prove the dessign is working?


interesting, but I don’t expect will allow test stuff with sillica components :frowning: Thanks!

Did you try using the QML live features in the SDK? For pure QML apps that works well. Every edit yous save goes directly live on the phone.

1 Like

qmlscene /path/to/qml

sailfish-qml appname

qmlscene works if there are no binaries needed (or needed plugins are installed).
sailfish-qml launches an installed app from /usr/share/appname/qml/appname.qml.


@poetaster I tried to have it working, but in linux simply crashed when I tested, maybe because it was not a full qml app? I will try it again on the flight-tracker, to see if it works

@nephros the sailfish-qml is what already does my app, in that case you connect to the sailfish os device and edit live there?


You can but you need to be root to write in /usr/share/applications/app.

IF your app is pure QML (or you have a mockup QML version of it), what I do is

  1. ssh mydevice
  2. git clone git+ssh://server/me/repo/ devel/app
  3. cd devel/app
  4. qmlscene qml/app.qml
  5. view qml app
  6. hack qml files
  7. repeat from step 4.

I’ll pull your last version and set it up to work in the sdk. now.

Ok, I cloned, opened the project and:

  1. Went to the ‘Projects’ Tab,
  2. Chose a build and then clicked the ‘Run’ tab
  3. checked ‘Enable receiving updates with QT QmlLive’

It just works. EDIT: This dev box is Ubuntu jammy.

thanks, next week I will have more time, and I will try again, maybe I contact via matrix to help me if I’ve got problems, but last week I tried in my linux and didn’t work.

My linux is a fedora 37, Did you use a real device? or the simulator?

I used a real device. I’ll try to make time although I’m on the road a bit for the easter holidays.

yeah, don’t worry, enjoy the holidays! :wink:

1 Like

Yeah! it’s working!!! It works really smooth! good way to test the UI!