[Solved] [Warning] Sailsync OwnCloud may skip files

I’m not entirely sure this is the right place, this is a warning, not a bug report or development announcement.

For some time I have had a problem with SailSync skipping files, in one folder containing about 1000 files, 18 was synced to NextCloud.

I found the reason the other day:

If your owncloud / nextcloud instance is on a https url, and http requets is rerouted with code 301, and you either have omitted the protocol or used the http protocol in the SailSync settings, the sync will fail silently after a few files!

This isn’t an error in SailSync, but a problem in the owncloudcmd used by SailSync.

The problem is solved by adding http:// to, or changing http:// to https:// in , the url line in /home/defaultuser/.config/harbour-io.edin.projects.sailsync-owncloud/config.ini.