[Solved] Slack Chat installation procedure - as of July 2020

Hi Guys,

Slack is now, post virus land, is becoming more and more a key part of business.

I am a new SFOS user, but long time *nix user.

I am using SFOS as my daily driver, hence will document anything i discover, where i cannot find it already addressed in this forum, in the hope to help others.

My findings are, as of July 2020:

  • Native apps like sailslack and slackfish do not work (unmaintained, it seems, as login is broken)
  • there is a ‘hack’ for sailslack which allows login, but photos are not really supported (cannot view photos in chats, or upload photos), which makes it unusable

So the only option so far is android version of slack.

So far, glitches with android version of slack are:

  • to upload photos, need to use camera app, then select photo using gallery select (direct cam use doesnt work well)
  • notifications dont seem to work

Installation of Slack for Android:

  • Install Aptoide store, by downloading APK and installing directly (https://aptoide.en.aptoide.com/app)
  • Search Aptoide store for slack.
    • for me, latest version did NOT work.
    • i had to install version (just choose previous version from aptoide)

enjoy. :slight_smile:



There is a patch for photos not being shown in sailslack:

1 Like

notifications fixed on slack app for Andoid:

  1. edit file /usr/share/lipstick/androidnotificationproperties

  2. add slack entry enable android notifications:


1 Like

Thankyou decon. i will give it a go. :slight_smile:

@decon - you mentioned its a ‘patch’

tried copying qml files - still cant view images.

do i need to get sdk and compile?

or am i missing something?

  • Rich

This method only works with the “old” Android support for 4.x and mobiles like J1 and Jolla C, or am I completely wrong?

@richarpad The patch had changes in a cpp file so it needs to be compiled in SDK. That is however a bit complicated since you need to create a new Slack application to be able to build the app.

I forked the app and uploaded it to openrepos:

You can copy your:
so you don’t have to do the login hack procedure again