[SOLVED] SF X bought, but won't flash. I know this stuff. Please help

EDIT: problem solved – flashing just wouldn’t work on the laptop, but when I tried on the desktop it ran no problemo on the first go! I’ll leave this here if it helps anybody. Moral of the story is, never give up, try everything and keep the faith :smiley:

Quick intro: bought used Xperia 10, found it has Android 10, managed a downgrade after 6+ hours of tries, dev options / usb debugging enabled and persists after reboots, bootloader unlocked successfully. On Linux, also tried on Windows.

So after all this, I’m ready to flash SFOS X. Hit a brick wall when fastboot just gives ‘Failed to get boot partition size’. Tried adding --force inside Jolla’s script, then tried manually with fastboot --force flash boot_a imagename. Tried to fastboot getvar:anything manually, but the phone won’t give out anything. It does give ‘already unlocked’ if i do fastboot oem unlock again, so it’s connected. Tried all this on my cozy Linux (fastboot from Arch AUR) and Windows with Jolla’s provided fastboot and a bunch of stupid USB drivers from xperiastockrom.com and Google. Set up an udev rule on Linux, so I’ve been able to try everything both as regular user and superuser.

I’m at my wit’s end, please somebody help. The image I flashed to bring the phone back to Android 9 was a ‘Commercial / Journalists’ image from XperiFirm. Is it likely this is the one image that has fastboot / usb debugging fudged somehow?

1 Like

Firstly “Commercial & Journalists” 53.0.A.2.139-R1A is the correct one as you thought. Is your Xperia 10 I3113 or I4113 (Single or Dual Sim)? What particular version of Windows 10 are you running and presumably USB 2.0 not 3.0? Must admit had to give up upon my I3113 where main camera functioned upon both Android 9 & 10 but just a “black screen” for viewfinder upon Sailfish OS.

Sound like the well known USB issues, which seem to occur primarily under Linux:
See description and solutions / workarounds for this.

Thank you for your replies! I fought my way through the troubles and now have a gorgeous and fully functional Sailfish Xperia 10. Mine is the dual-sim 4113.

It was a USB issue in the end, didn’t flash with Surface Go running Arch Linux, but went downstairs to my desktop Thinkstation with the exact same Arch Linux on it and there Jolla’s flash script worked first try.

Once more, thanks so much for reaching out! This is a great community, hope to do my part in the coming times…