[solved] How to update Jolla from to 3.4?

I’m trying to update my Jolla from (Saimaa) to the latest version, which should be 3.4. When I try to update via “Sailfish OS updates” in the settings application, no update is shown. And when I select “check for update”, it only shows “Waiting for connection…” for some time, then stops without showing any update or error. Internet connection is available via wifi.
Any ideas? Should this update process still work, or is there a different way to do the update?

If you are not afraid of the command line, you could use sfos-upgrade. It woukd be best to use it via ssh.


Sorry, it is available on openrepos or chum.

thank you for this quick reply! I am not afraid of the command line, I basically live there.
I did find sfos-upgrade on openrepos. I will try that, thank you!

You’ll need to apply this guide before using Storeman and your problem is perhaps related to the same issue : [Guide] Fix certificate issues on SailfishOS


thank you for all the tips. The first update is finished, and the next one is running. I will let you know if I make it all the way to 3.4.
Mentioning sfos-upgrade was very helpful, as its output showed that some file could not be downloaded. And then I remembered that I blocked some of jollas servers in the hosts file many years ago.

1 Like

I have finished the update to 3.4. It took a couple of hours, but everything appears to have worked just fine. Thank you for the help!