[Solved] Botched up installation of Quartermaster

(This might be something for @BlacksheepGER …)

I was exoerimenting with Home Assistant yesterday and started off with a test installation on a test machine. I got that running and to round off the test, I also installed Quartermaster on my Xperia X (4.0.1 - on the one with 3.4.x, Quartermaster does not install, it seems). Got it connected just fine, everything working.

Later yesterday, I decided to set up Home Assistent “for real” on my server, so new installation on a different IP. Once that was running, I ditched the test installation and went on to try and reconfigure Quartermaster. To start with, Quartermaster just hung upon start (I waited minutes…). So, apparently, no direct way to reconfigure. I then proceeded to find and remove all quartermaster files in the home directory of “defaultuser” (including one in “privileged”), then removed and re-installed Quartermaster. No dice - upon start, Quartermaster still hangs. I repeated that process, this time also deleting a lock file somewhere in /run/user/100000/single-instance-locks/usr/bin/harbour-quartermaster/ and another re-install. No luck - Quartermaster hangs.

I then proceeded to try and investigate this from the command line, so I fired up harbour-quartermaster from a terminal - and then it did start and showed the installation wizard. I completed the configuration, entered the token again and got it connected to the new Home Assistant instance.
Unfortunately, this was not the end of it - when I closed Quartermaster again, I still could not start it by tapping on the icon - it just hangs. When I run it from the command line, it does start, but does not store the configuration - it shows the installation wizard, where IP and port are correctly filled in, but not the access token.
So, the question is: what do I need to do to actually start with a clean slate with Quartermaster, so I can configure it from scratch and use it normally from the icon afterwards?

I can confirm some similar behaviour on a X with
At some point of testing Defender could not be started anymore by tapping the icon in launcher (no instance running, checked). But it did start from command line!
I did not investigate any further but reflashed (also due to other testing…).

Maybe worth a bug report?

1 Like

Hi thanks for your feedback!

I think the trouble maker is the Sailfish Secrets part which stores tokens and / or my serialization of this stored data. At the moment I am rewriting the application core and noticed that too.

The problem seems to be that the app looses the access to this secret data and can not create a new one as long as the secret collection exist.
I will try to make a fast fix for this before proceeding with the new application core. Maybe a simple reset button in the setup wizard that removes at least the secrets collection and maybe the whole configuration.

1 Like

New version is out with possibility to reset the stored secrets in Sailfish Secrets:

  1. on intro page of setup wizard
  2. in settings on page “Device Info”

Hope this helps!

1 Like

Yes! I got it working again with the new version, thank you! However, there were two minor issues:

  • When I used Device info -> Reset, Quartermaster vanished (looked like a crash) - but at least the set-up wizard started again when starting the app again
  • When entering the new host information in the wizard (IP and port), I could not swipe left to go further - the swipe dot was greyed out. At some point after swiping back and forth and changing the IP once or twice it suddenly became active and I could continue. After that, everything worked fine.

Good to hear it helps!

  • I close the app when registration is deleted. This is the “normal behaviour”.
  • I will check this
1 Like

Ah, that explains it. From a “simple user” point of view, I would appreciate some kind of warning, as I associate an app that “vanishes” with crashes and other “bad karma”… :grin: Other than that, I’m really happy! :+1: