[SOLVED] Anyone having issues with the SDK 3.2 repos?

Anyone having build issues with the SDK 3.2?
I’ve refreshed all the repos from the control center but still getting build errors,

:-1: error: nemonotifications-qt5 development package not found

Will just ping @martyone, btw what OS etc? I still haven’t pulled the plug so sadly cannot confirm or deny, tried both EA and non EA but no luck at the moment.

Windows mac linux? Which version etc… means practically nothing when it comes to sdk, you have an issue with your host OS not the build target I assume

Ah, sorry long day.

Windows 10 2004, on SDK 3.2 with SFOS build engine not docker.

Any other details I can add?

Sounds good, have you updated SDK or fresh install? I have the same setup so when I get the balls to do it (update) will confirm your findings probably (any specific project it failed with?)

1 Like

Do you have the following in your .spec file?

BuildRequires:  pkgconfig(nemonotifications-qt5)
1 Like

For some reason no, my other project did have it but both built fine on SDK 3.1 after I refreshed the repos which is odd, all fixed now though with the addition, thank you both for your help :slight_smile:

I believe you didn’t hit this before because you built the other project first. This way the devel package was pulled in and so it was available at the time you built the project which does not declare the dependency :slight_smile: Note that the error message comes from pkg-config, not from package manager.

That would explain it, thank you :slight_smile: