[solved] [] gallery and documents app doesn't start

REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION: If I try to start gallery or documents app, app cover appears with running circle, but some seconds later it disappears without starting the app.



EXPECTED RESULT: apps should start

ACTUAL RESULT: apps doesn’t start


Reinstall documents app doesn’t help, reinstall gallery app not possible to me.

Hm, I’m the only one with this issue?
Now, as was rolled out to all users, there is no hope for a quick fix.
Is there anyone with a hint?

I have just updated to 4.4. Several apps fail to open or work properly including the Gallery app. It opens but when you select “Photos” or “Videos” or “Screenshots” you get an error message " Could not load page" On the home page of the app there is a carousel of thumbnails for each type of image but you are unable to open them

After updating to 4.4 I got a lot of issues:

  • aliendalvik-control can’t be removed
  • jolla apps like email, calendar … don’t start
  • the update process showed a message like “something went wrong, the update could not be completed” although the update is available.

How can I reflash manually the update 4.4? The phone isn’t usable for me in this form.

Just reflash SFOS following the instructions here: Sailfish X Installation Instructions - Jolla

After doing tracker3 reset -s not only this problem is solved, but also gallery and documents start again as expected.
Problem solved for me. No bug.

No, after running “tracker3 reset -s” nothing changed, almost all Jolla apps do not work, but Android apps do.

Can you share the output log if the app is started from terminal?
For instance:


Oh, the calendar app starts but doesn’t find the database …
[D] unknown:0 - Using Wayland-EGL
[W] unknown:0 - Unable to create database directory: “/home/nemo/ … /mkcal”
[W] inknown:0 - sqlite3_open error: 14 on database “/home/nemo/ … /mkcal/db”
[W] unknown:0 - unable to open database file

Thanks for your help

I’m wondering if it would help to change your username. But I have no clue if it’g a good idea or not…

The database is protected by a different group. To start the calendar from CLI and make it access to your database, you should type devel-su -p jolla-calendar.

Okay dcaliste, that worked for me - I started the Calendar app via CLI. But I can’t launch it by clicking on the app icon. How can I configure the system to run the apps correctly again? Thanks for your support

You can find in the desktop file /usr/share/applications/jolla-calendar.desktop the execution command that is run when tapped. You may thus try from CLI /usr/bin/sailjail -p jolla-calendar.desktop /usr/bin/jolla-calendar to see what are the reported errors when the application icon is tapped.

I got this message:
…daemon.sailjailclient.c:621: client_prompt_permissions(): E: org.sailfishos.saijaildl.PromptLaunchPermissions(jolla-calendar): failed: GDBus.Error:org.freedesktop.DBus.Error.AuthFailed: Not allowed

Another problem is I do not have network access via ssh …

That is bad. You should open a new bug report, because we’re diverging quite far from intial report.

The problem is that somehow the system cannot open the permission request window.

I was wondering what would happen if the /home/nemo directory were copied to /home/defaultuser … but that’s just idle speculation.

or move most adequate files, delete and symbolic link one to the other?