Soft reboot bugged loop / PIN check never progresses

Fresh installation of on Xperia 10 iii.

This is a modal problem and last time it was triggered by a hard reset.

The initial PIN check doesn’t resolve ~80% of the time. The circular wait graphic repeats forever.

Breaking the cycle by going into the Recovery menu and powering off before cold resetting works 3 for 3 times so far. I suspect the failure of flash procedure to properly finish is the cause.

[Moved from General]

For me it worked to wait exactly 7 seconds on the 10ii. Then it almost always unlocks after 4 rotations

Wait before rebooting or wait to input passcode? It reboots automatically so I can’t wait before rebooting. Holding the power button during boot or at the passcode screen invariably reboots automatically here.

You can try to force power shutdown by holding up(?) volume button while pressing power for like 10 seconds (wait for 3 vibrations), this can fix some things unlike normal reboot, but is not advised and can cause loss of data, but seeing you also posted in release notes thread about fresh install, maybe try reflash with different android base, looks like something went wrong with the flashing, such issues aren’t normal on fresh flash (or maybe just faulty unit? Is android fully working and stable?)
Edit: or a different usb cable, or port, or host OS, but get the flashing process from start to finish without hacks and workarounds, getting buggy pin entry suggests you didn’t flash properly

1 Like

I had this happen semi-regularly for a while earlier this year on my 10 II – I don’t remember exactly what version(s) of SFOS I was using. The hard-reset button combo and waiting for the three-buzz confirmation always got the device to reboot normally, but sometimes required more than one try. I hadn’t heard the wisdom/lore about the data loss possibility.

I also suspected but never confirmed that the passcode dots appeared slightly different when the phone was going to go into the infinite spinner of unlocking mode.

1 Like

Before entering the passcode.

1 Like

I have the feeling this depends on how much data has to be decrypted

1 Like

I downgraded from Android 13 to Android 11 via Emma as recommended – indeed from the first appearance of the GUI to ensure the unlocking. The failure of fastboot to reboot properly has been noted by a few people.
Not easy to change host (Windows 10) or USB cable [worked for years].
I didn’t use Jolla’s recommended ADB driver, but the one from, so that I can change.

This looks like an actual bug since other people are having it, so moving it to Bug Reports.

My XA2 had no problem with this in spite of its much weaker processor. So I rather suspect it’s something else slowing down the decryption, something which is a consequence of the warm reboot.

My XA2 did have a problem in the same part of the boot process if it was charging. It may be invoking the same bug.

This seems common, so seems unlikely to be related [to this uncommon issue].

Then please use the bug report template.

1 Like