Situations application feedback

Opening a topic for SItuations application feedback & discussion with the developer directly.

Latest packages always available here before Jolla Store: Releases · pastillilabs/packages · GitHub


Very nice to see you’re still working on Situations app :slight_smile:
Will give it a try, glad to see Sonar going away, i got tired of having to stop it, then launch Situations, then start it!

I can’t get it to work. It’s stuck on this page. 10 III, latest SFOS.

1 Like

You didn’t specify if you did allow untrusted software in Settings.

btw I like your avatar @hhaveri - are you an Amstrad CPC enthusiast by any chance? (since this is coming from Bruce Lee on the CPC) :slight_smile:

Yes, I did (I don’t think I could install it otherwise…at least, not without the terminal).
I installed the app, installed the daemon, and then it got stuck.
I tried opening the app through the terminal but it got stuck in the loading loop.
I will provide more details once I get in front of my computer.

That also reminded me that I had a blog post about Situations app finished and ready to be published for a while - I updated it and it’s now live - Situations app on Sailfish OS

1 Like

I played Bruce Lee on C64 :slight_smile:


And you don’t have any other mechanisms installed for starting the background service?

Installing situations-daemon should autostart the background service as root.

Package sources are available here: GitHub - pastillilabs/situations-daemon: Background service launcher and plugins for Situations application

Welcome hhaveri. I didn’t notice donation button outside of your great app. If that is intentional then fine but you deserve donations for your great work IMHO.

1 Like

this is a very good point - i was about to check if there’s a way to donate

Not that I know of. I’ll reboot the device and try again.

I get the same error as described by branja6 and use a X 10 III too. I checked if the service is installed and indeed it’s active.

A reboot changed nothing. I’ll try tonight on a vanilla device.

1 Like

The view is shown when UI cannot - for whatever reason - connect to the server using a local socket.

I’ve only tested this on a developer enabled SFOS on Xperia 10 II - and in emulator of course. The server is checking that connection comes from harbour-situations2application (like Sonar did). I hope there’s nothing in sandboxing or system in general blocking that local socket connection - otherwise more hacks around it may be needed…

There might be some logs like “Connection refused: client not accepted!” in system logs in case the connection is just refused by the server.

Developer mode should do nothing to this; but SDK-started instances of the app are unjailed.

What kind of socket?

QLocalServer with QLocalServer::WorldAccessOption.

It does work for me (not starting from SDK) and apparently does work for some other folks as well. So difficult to say where the problem lies.

So Unix Domain Sockets? That sounds like something the jail would interfere with.

Nor from command line?
I.e. from tapping the icon.

Yes, and tapping from icon. And apparently also with developer mode disabled.

And you of course don’t accidentally have sandboxing disabled in your .desktop file, as opposed to what is shipped?

Then i’m out of ideas.

No, I have running what is shipped as is.

Anyone else managed to run the app or hit the same problem?