SIP on Sailfish/Aurora with s1p works, AFAIK. See a post above. I heard the telco saying it couldn’t connect, but a DAHDI got busy on my Asterisk box, which is somewhere misconfigured… Didn’t hunt it down yet.

Edit: May be not. It looks like it ignored “@” and the rest on the right…

@amaretzek: From s1p I have only access to the call history and not to all entries or numbers of a person in ‘contacts’. That means, only connections from the past are listed here on my phone.
Its a Xperia 10 / SFOS (Pallas-Y) Adaption, Encryption of user directory shows as active (LUKS 1). s1p version is 0.9.1-1, updated today (Nov.24).

I can find no way to enter any letters into phone number field, regardless what type of, tel, pager, fax, whatever.

Writing the sip-address into the notes field of contacts is senseless, because s1p shows only the call history. Maybe depending on program versions?

But surely a good idea to write sip adresses into the notes field of a contact and then C+P it into s1p. This works. A more convenient way is to store someones sip address in the contacts as an e-mail adress. Then search the person opening contacts, long-tap on the sip address, store in clipboard, then paste into s1p. This seems to be the convenientest way…

@unmaintained: With walkie talkie I wanted to say, a connection between 2, 3 or 4 people and not connected to the public phone network. Maybe ‘closed circuit’ would be the better word for this. Despite - or because :wink: - I am radio amateur, nobody in my family is willing to use a PTT button… :wink:

Still remaining the problem, that a call is not established. Both phones s1p running and online (logged in, ‘Registered’ message on screen)

If I try to call the other phone, then on the top appears
‘From’ (rest of line empty)
‘To’ (rest of line empty)

Then (blue) Call
Then 3 buttons (icons) speaker, headphone, mute

On tapping the highlited green handset, it turns not highlited, and then the app hangs (crashes).
No connection is established and the other phone does not ring.
It’s not possible to ‘hang up’ with the red handset icon.
Have to quit s1p to escape this situation.

The one calling phone has internet connection via the built in SIM card and the other one via WLAN to a 3rd SFOS phone working as a wireless access point and s1p not running but installed. In the other direction, if the other phone is the calling one, it’s the same behavior.

That’s strange. You should be able to call a person from the Contacts page in s1p as long as the contact has an associated phone number. Still, not a real help as there is no way to enter anything other than numeric digits into that field.

You can’t use full SIP adresses with s1p at this point, you’re limited to just the phone number (or user name) part. Means if the login name is “test123” you have to enter (or paste into, to be precise) just that.

It’s a hit and miss. It does work sometimes and it sometimes doesn’t for no apparent reason.
If you’re not bound to use linphone you may try out a different service like or

Will s1p’s source become open?

It’s more likely than not.

1 Like

Hello, I’ve asked in ‘feature requests’ thread for an option to enter SIP proxy; just wanted to drop a line, that I’ve successfully *) configured my company-provided account by:

  • entering what was given as “proxy” into “server name/domain” field
  • ignoring supplied “domain”

Hope someone will find it useful.

*) that is, registration and outgoing calls work, I’ll test incoming tomorrow, don’t want to alarm the poor guy who is on call this night and would get the call also

Thank you, now I need one android app less.

You may also add such feature requests to the issues tracker, this way they don’t get forgotten that easily and may be added at a later date.

Btw. is anyone interested in the UI being translated to other languages or is this something nobody really cares about and wasting time on that (which means less time spent on other features) makes no sense?

(My personal opinion) English is perfect, no translation necessary.

What I would like is in ‘Contacts’ an additional option to enter an alphanumeric SIP address (like e.g. ‘’) in the ‘Phone’ section of an entry, and in s1p an option to enter alphanumeric SIP addresses direct into the present only number input field, a possibility to switch s1p’s keyboard between numbers and letters.

1 Like

imho translation is a nice-to-have feature as s1p is not a product to sell.
Nevertheless it should not be neglected but keep coming fixes and features first.
Thank you
(even I cannot use with my FritzBox :frowning: )

Unfortunately I don’t own a FritzBox myself so can’t really test against it but you may try uploading a log file.
If the problem is super obvious I may be able to create a fix nevertheless.

1 Like

I can translate to pt-PT. DE too if nobody else jumps in…

Did so under issue #47.
Even mine is a different model but that should not be the problem,
This is internal connection. External does also not work but step-by-step :wink:

Thank you for providing the log trace.
Could you please test it again with version 0.9.2

1 Like

No, thank you…

…for fixing it! :slight_smile:
Internally I can connect now and call and receive.
BIG thank you.

From externally it still hangs on registering. I have uploaded log #70 and do hope you see something ‘obvious’ again.
The account is working and reachable from outside, tested with Android SIP client via cellular data (speech is not working on that Android phone but that is another story I guess, connecting and making/receiving calls work).

Could you please upload one more trace with the option “Use rport” enabled (in Settings)?
Thank you.

1 Like

Magic setting rport.
Registered and calling/receiving works (but speech is not working both directions :frowning: )
Uploaded nevertheless log #71.
Thank you for this wonderful piece of SW!

It is so long ago when I played with my Symbian and N9xx configuring SIP that I forgot almost everything. But I remember I had such issues then as well.

Anybody any idea?
(internally connected all is fine, connected from outside speech is not working, with FRITZ Box)

I have to admit I can’t even see s1p trying to establish a call in the log trace :grin:

1 Like

That is because I stopped logging before trying speech. :roll_eyes:
Should / may I send another one?

And, out of curiosity, what does this magic setting ‘rport’?

If you want me to take a look at it then, well, yes.

It requests the server to send the response back to the source IP address and port where the request came from and not the ip/port combination stated in the SIP headers.
It’s meant to help with NAT traversal.

1 Like