Silencing notifications per app?

Hi, a silly question.

How do you silence most notifications, and decide what you what to hear?
For me, all things I want it to “beep” are:

  • phone call
  • SMS
  • Whatsapp or Slack message directed to me (yes those are Android apps)

In every other case I don’t want beeps. I don’t give a crap when new email is received etc… I almost lost it whet it beeps and says “a new device is accessing your Whatsapp”!! **** I care!

To think it furher, I also don’t want LED to reflect say unread emails. That would only mean that its
on all the time. Useless.

How do I configure that?

(I have Xperia 10 II, with the very latest SFOS)

4 Likes

+1. In particular, I did not find a way either to configure Whatsapp to play a sound only when there is a direct chat message to me, and only display a notification if it’s a group message. I set Notification tone:silent for groups inside Whatsapp’s settings, but that seems to be ignored. This used to work on an Xperia X with the old-style Aliendalvik 4.4 though.

I imagine there is a “translation layer” inside Aliendalvik that ignores these settings, but it is unclear to me how that works exactly.

Indeed. I got it “somewhat” better in Xperia X - but I’m now back in the notification hell!
In the Samsung S9 where I’m swithing from, there is a nice UX for per-app notification prefs.

And to be honest, disable all seems so nice! But I’m not the SoMe user who is interested in this crap.
→ you’d still want the calls and direct messages.

Sorry from spamming - I’d like to have a policy of alerts/notifications, where everything is denied, unless you allow specifically!

Here you go again: “Whatsapp web is now active.”

I could not care less, how do I stop it from beeping?

Jolla, if this is difficult, can we have a whitelist instead?

1 Like

Anyhow, here is my (partial) advice for what can be done now:

  • in Settings/Sounds and Feedback, you can set “no sound” for e-mail to silence incoming e-mail notifications. It applies also to Android mail apps like K9. Similarly you could silence all chat, but it is too broad for my needs and I would love to have something more fine-grained.
  • in Settings/Apps//Open Android Settings/Notifications, you can see more settings and prevent some types of events from showing notifications completely. You can also click on a notification type and choose between Alerting/Silent to silence the sound, but (at least in my experiments) this setting does not work and it does nothing. All Whatsapp notifications still play the ‘ping’ sound, irrespective of that setting. ¯\_(ツ)_/

Still hoping for a better solution in future; this is far from satisfying, especially because it is a regression from the behavior on Xperia X.

Go to Android settings for WhatsApp and disable “Other” notifications.

For email I just have it on manual refresh, although I still have to delete the notifications.

Just noticed this page from Jolla https://jolla.zendesk.com/hc/en-us/articles/203442828-Setting-up-WhatsApp-on-your-Sailfish-OS-device :

  1. Selecting ringing tones and notification tones

Open Whatsapp app. Tap the three dots near the top right corner and select Settings. Next, tap Notifications. On this menu page, you can select in which ways you want Whatsapp to alert you on incoming messages, group messages and calls.

So this guide implies that it should be possible to turn off notification sounds for group messages separately from those for direct messages, do I read that correctly? Am I the only one for whom this does not work at all?

So there is no way to get rid of the email notifications altogether? They are useless.

I assume you succeeded in silencing email notifications. Have you read LED Howto? You could try to play with PatternCommunicationEmail in /etc/mce/20hybris-led.ini. Set the color to black 000000. Just an idea, I have not tried.

Hi @henris42 !
Stop email notification works when you stop auto synchronize your account.
The other way is to go to -settings-, then -ambience-, choose your ambience you want to configure, then from the bottom -add action- (or something like that; my gui is in german) add -email- sound and choose -no sound-. Done.
Now in this ambience you won’t get notifications for email.
Hope it works for you, broncheolus.

What should also work, but I haven’t tested, is:

dbus-send --session --dest=com.nokia.profiled --type=method_call /com/nokia/profiled com.nokia.profiled.set_value string:"ambience" string:"email.alert.enabled" string:"Off"

Look up values with:

 dbus-send --session --dest=com.nokia.profiled --type=method_call --print-reply /com/nokia/profiled com.nokia.profiled.get_values string:"ambience"

Thanks for all for help, I did indeed succeed to make it much more tolerable will all these instructions. I haven’t tried the LED thing though…