Signal registration troubles on SFOS

Since a couple of days, I’ve been trying to restore my Signal account from an old device, after moving to xperia x-iii.

  • Transferring the backup and opening it with the passphrase went fine, but the code that was sent by the signal server was considered consistently incorrect (tried 3 times over the last days).
  • Afterwards, it would not even send an SMS, but just claim that there are too many attempts (giving a waiting time, which I always let pass).

I gave up and simply tried to register a fresh signal account. But the same thing happened also here.

  • There is also the peculiar note that says “Missing Google Play Services”. This shouldn’t appear, should it?
  • Signal was downloaded first from the APKPure store, and then deleted and downloaded again from Aurora store.

Maybe someone has had a similar experience, so any clue would be welcome.

For the second part of your issue, you have to go to and download directly via the big blue button beyond the “Danger Zone”. Just in case, read the warning.
The good thing about the Signal app is that you will get a popup telling you when you will need to update, even without third party stores.

I feel only fair to remind you that there is a very solid native alternative through openrepos called Whisperfish by @rubdos that you may want to try, given that you are starting from scratch now.

For the first part, I’m afraid I can not help much, sorry.


Hello. I am in the same boat. Just tried to register. Blocks me every time. I have to wait 4 hours now. I will try tomorrow.

I recently restored a Signal account on a XA2, downloaded from, and the SMS codes were accepted.
I did have that missing Google services note, but usually it can be ignored.

It actually works for someone? I tried it twice and messages just weren’t sent nor received.

ah ok! Where can you download it at I only found a link to the Google Play Store.

Ah right, @marbalf, you mentioned that it is in Signal >> Signal Android APK.

yes, I sometimes did get back a message in fact. But the code contained in it was not accepted after I typed it in.

Same problem. I noticed that there is a new version of Signal in the APK page. However, now I can’t even get a Captcha pop-up.

It worked a few months ago.

I have the exact same issue.
Contacted the signal support but no feedback so far.
If i wait a long time and try again, I do receive a new code per sms but it’s considered incorrect by the app :confused:
Will let you know if I get a feedback.
It did work ok before on XA2 using apk from signal official website.

Just installed new version of signal from signal official website and the code received by sms did get accepted this time :slight_smile:

1 Like

This should be flagged as solution as this is exactly what I did last time.

1 Like

Had the same issue for the past week. I can confirm that todays release fixed the problem

Thanks to all of you!

For anyone with similar issues:

  • the message “Missing Google Play Services” has nothing to do with it, you can ignore it.
  • you can get the latest version of signal from the “danger zone” on
  • the issue seems now to be solved also in the new version in the app store.