Short Volla Report

Hi! I just wanted to report that the 3.4 SFOS release works well with the Volla phone. Some aps which haven’t been updated recently (Fahrplan, for instance) segfault, but most things work as expected. I mean that in the sense of comparable to my experience running the Jolla phone.

What’s missing from the hardware support front is, in the main, the camera. It’s clear you’re only using one camera and that’s qualitatively inferior to android.

Still, everything else works as you’d expect.

I’m going to use the device daily and try to fix a couple of apps (Fahrplan, for instance :slight_smile: ). And get my Fairphone2 working again.


And recompiling Fahrplan for 3.4 (without other changes) worked. Only the german backend ( was active, but it’s a start!


Great ! Which version did you download for the Volla phone? … I see Sony hardware only.

I just downloaded the Ubports installer and installed it, then chose SFOS …

If you have/get a volla with ubuntu touch installed, you have to install volla os (android) FIRST and then Sailfish.

1 Like

Two items one cool, one not. Bad news first.

  1. At some point (which might have to do with doing developer stuff) the orientation sensor ‘goes away’. I’m pretty certain it is a developer thing.
  2. To do more thorough testing, I bought a Gigaset GS290. You can install SFOS on it with the ubports installer (took 2 tries, not as easy as the volla) and it seems to be identical to the Volla!

Yipee! another phone to hack. Well, ok. It’s the same phone :slight_smile:


do not tell it in volla form. some people there would go crazy. i run sfos from sdcard using multiboot. it freezes now and then and i have to reboot. like every second day on avg. does it happen to you too ?


Please let me ask: I bought a new Volla phone with pre-installed Ubuntu touch. Doesn t sync unless I write skripts and whatever to activate evolution sync etc…I don t want this.
In case sync is possible with SF as I can use it with android: How to test SF fully and where to download and how to install with a windows pc.

I am not too experienced with skripts etc - can you advice me?.

Yours sincerly


My volla is solid as a rock. And I did buy one after all :slight_smile: I bought the GS (for 105 euros!) because I couldn’t find out why my orientation sensor fails. Thought it might be hardware. So i couldn’t afford to buy another Volla just for testing.

Only the orientation sensor is screwy. And I think that has to do with me doing developement on the phone. I’m running that on internal flash.

The GS290 seems identical to the volla.

With the ubports installer you can install Volla OS (android without google) and SFOS.

I would suggest you go the VollaOS (android) route if you don’t want to deal with scripts ‘at all’ …

The Fahrplan from openrepos crashed BUT the Fahrplan (without calendar integration) on the Jolla store works fine … on volla with 3.4.

Sooo, short story, the sensors on the Volla (and the GS290) were being killed by developer repos:

disabling them:
ssu dr adaptation-community
ssu dr adaptation-community-common

‘should’ work.

To fix I actually pulled the original files and copied them back by hand.

Wow, thanks for all your research, the gs290 is very interesting, except it’s even heavier and bulkier than the xa2ultra which is like a brick in my pocket. I’m going to dump it and go back to xa2 or maybe even x, definitely the best designed.

1 Like

If you don’t need performance, one can still pick up a fairphone2 .,… that’s a small light phone.

The adaptation-community repos were reanbled after piggz made a repo change AND i set it to testing (not dev). I’m looking to find where exactly I set this!

Maybe some else picks this up. I’m looking for the the enabled repos, but zypper (/etc/zypp) is not the location, I believe?

Thanks! I can’t keep on top of all the channels. Let’s make it explicit ‘here’:

Edit the file /usr/share/ssu/features.d/community-adaptation.ini and change the word

devel: to testing

in the url, and change the end of the url to

sailfishos_{RELEASE} from sailfish_latest_{ARCH}


[root@VollaPhone Databases]# cat  /usr/share/ssu/features.d/adaptation-community*
repos = adaptation-community-common
pattern = Feature adaptation community common
description = Common packages needed by community's HW adaptation

adaptation-community-common ={RELEASE}/

repos = adaptation-community
pattern = Feature community adaptation
description = Enable ssu for community ports

adaptation-community ={RELEASE}/

Make the same changes in community-adaptation-common.ini

Then run

ssu ur
zypper ref
zypper dup

1 Like