Shift and Control keys don't work on Bluetooth keyboard when on Android

REPRODUCIBILITY (% or how often): always
HARDWARE (Jolla1, Tablet, XA2,…): Xperia XA2
REGRESSION: (compared to previous public release: Yes, No, ?):


When using a Bluetooth keyboard on Android apps, Shift and Control keys don’t work, so for instance pasting text or copying it is not possible


I’m using a US keyboard layout, and SFOS is also set to US English.


  1. Copy text from another app (either SFOS or Android)
  2. Open the Android app
  3. Try to paste with Ctrl+V


Copied text should be visible


Only a v is displayed


Apparently this used to work (according to @dexic on SFOS Telegram User group). with US keyboard layout.


answering to myself: workaround is described here:

This behavior also concerned with an Android device. That’s why there is the “External Keyboard Helper”. BT keyboards don’t always follow the magic rules. Have fun because languages other than English (qwerty) are ignored by the Dalvik (BT).

as a finn i agree that the current situation vacuums a bit. i had plans to use my sony z3 compact tablet for actual work purposes, but without even capital letters it’s impossible…

And the situation is still the same for SFOS… I can only use the English layout, which is fine for terminal work, but having a Finnish conversation without ö and ä is dumb…

Dear sailors,

I have tried the solution with External Keyboard Helper for Android and it doesn’t work any more. Something has changed from 3.4 to 4.0 and made this impossible.

Now, does anyone know a workaround to paste text into Android with connected hardware keyboard, so that I could type text in a note and then copy and paste it into an Andoroid app?

Thanks a lot!


Okay, found one solution to get this going.

  1. Install External Keyboard Helper from Aurora Store or wherever you get it from.
  2. If the app hangs with updating the screen, swipe into the screen from the left to show a bit of the notifications - and go back again.
  3. Go to Advanced Settings > Other Settings > Diagnosis
  4. In there try your keyboard, what signals it will send to AD. Remember the Device-ID!
  5. Go one step back into Other Settings and to the top > set device ID filter. In there set the filter that you have seen in the diagnosis screen.

I think that this has been all that I have done.

Have fun with it!


Sorry, my bad. Shift works in Sailfish apps. Browser works so well now I thought I was using Firefox instead :sweat_smile:

The situation with Android is still the same - no shift nor control, layout switching doesn’t work (can’t select Finnish either from Sailfish Settings Android settings nor ctrl-space).

You should try my workaround. :wink:

Still the same situation on SFOS 4.2 EA.

You mean that the workaround is needed? As long there is a workaround, they have no pressure to fix this.

There is a new post, that some checkbox can’t be checked. This is the same phenomenon with my post, but I sometimes even can’t tap on any button.