SFOS Menu Icon Size - Can This Be Changed?

Compared to the Xperia 10 iii the size of the menu icons on the XA2 is much bigger, so you can fit less rows on the screen. I assume this is because the resolutions of the screens is different across the two devices.

Although there is an option to make the onscreen text bigger or smaller in Settings/Display, there is no option to change the size of the menu icons.

Is there any other way of changing the size of the menu icons (e.g. By changing, say, a config file dpi setting or something)?

1 Like

Using ‘launcher combined patch’ from patchmanager you can change the icon size and some other things.

1 Like

Maybe this might help? DPI change in settings

1 Like

Thanks, but unfortunately the Launcher Combined Patch is only for SFOS v2. It doesn’t work on the latest release.

works for me on 10ii. Have you got the right patch? Mine is a fork of the original made by carmen for 4.4/5


The only Combined Launcher Patch that shows up for me on Storeman/OpenRepos is one from 2018.

I can find nothing on Chum either. So not sure where the later forked patch can be found?

“Using ‘launcher combined patch’ from patchmanager” => Project: laucher_combined_cfb


Search launcher combined patch from Web Catalog in Patchmanager and install the one I made.


Ok, when I figured out how to use Patch Manager (be kind - it was my first patch!) I could then find the Combined Launcher patch. I’ve installed it, after disabling strict version checking, and it works. Thanks to all who posted helpful advice.


Hi Carmen, I tinkered with the launcherLayer.qml and this stopped launcher combined from working. I reverted the modifications, uninstalled patchmanager, reinstalled but still cannot activate launcher combined. Any idea what the correct sequence is? Are there any files that need deleting?
this is a bit OT for this thread but seems the right place to ask

Maybe your launcherLayer.qml file is different than the original one, and for this reason the patch isn’t working.
Did you uninstall my patch before patchmanager?

launcherLayer.qml should be exactly as before. I didn’t uninstall patches before removing patchmanager…
edit: tried uninstalling patchmanager and deleting all data from /usr/share/patchmanager but when I reinstall I see the settings are not the defaults but the changes applied previously and I can install the patch but can’t activate it. Any clues? I really miss the folder icons on the homescreen.

Sorry, I don’t know how to help you. I think you have to uninstall patches and then patchmanager.
Did you get any log in/tmp/patchmanager3/?

got a log, here’s an extract, btw, note your typo “laucher” instead of launcher
GNU nano 6.4 patchmanager.log
*** Patch-log created by pm_apply script 2023-11-20T09:44:12+01:00 ***

pm_apply 2023-11-20T09:44:12+01:00

ERROR: /usr/share/patchmanager/patches/force-cover-size is not a directory or does not exist!

*** FAILED ***

pm_apply 2023-11-20T09:45:02+01:00


Using patch file: /usr/share/patchmanager/patches/laucher_combined_cfb/unified_diff.patch

Checking paths for 64-bit → 32-bit conversion

Mangle candidates: /usr/lib/qt5/qml /usr/lib/jolla-mediaplayer /usr/lib/maliit/plugins

OK, found nothing to convert.

Test if already applied patch

The next patch, when reversed, would delete the file usr/share/lipstick-jolla-home-qt5/launcher/FolderIconBigGrid.qml,
which does not exist! Ignore -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
The next patch, when reversed, would delete the file usr/share/lipstick-jolla-home-qt5/launcher/FolderIconCascade.qml

I don’t see any error and no success message either, the error in name (laucher instead launcher) is not important here. I don’t know why it’s not working for you. As I said before, I think you modified something that it’s not reverted when you uninstalled patchmanager, so you don’t have original LauncherLayer.qml


Have you tried reinstalling the lipstick-jolla-home-qt5 package?

1 Like

Thanks miau, that did the trick - when I reinstalled patchmanager this time I got the default settings. Installed combined launcher and got my folder icons back.
Thanks Carmen for your patience.