SFOS android email apps not connecting to WIFI

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 3.4 now 4.0.1
HARDWARE (XA2, X10, X10 II, …): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:Starting on the morning of 21/07/2021 my email apps, Fairmail & Protonmail stopped notifying me of emails. I checked and Fairmail was claiming to not be connected to the internet and Protonmail was flagging up being Offline. My WIFI (I checked) was on and Firefox browser was working fine.
I was not messing with anything as I wouldn’t know what I was doing (not familiar with coding/script or whatever it’s called) and everything was working fine in SFOS 3.4 up till then.

As my android email apps were shot I thought I’d try the Jolla email app and that set up just fine and has zero problem getting my emails. I then went to look for alternative android apps as I thought maybe the problem was the android email apps themselves so I tried and other email apps failed as well.

At a loss and not knowing how to fix the problem I thought finally updating SF to 4.0.1 might offer a fix but nothing has changed, android emails still not connecting / offline despite perfectly good wifi. I installed the most recent version if Alien Dalvik to see if that might help but even after reboot Alien Dalvik is not functioning (I can open it, switch it off and on but no button or other options are responding but that’s a different problem. I think?)

It’s as if all of a sudden the android side of things is not recognising the fact that SFOS side is connecting the phone to the wifi.



  1. Open Fairmail or Protonmail, Protonmail tells you that you are offline
  2. Refresh Fairmail, it tells you that it has no WIFI connection.




(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

I can confirm on Sony Xperia 10 II, SailfishOS parts of the OS connect fine to Network, Android does not connect to network.

Have you tried turning wifi off and then back on?

Thanks for the reply SGE but try XA2 (single sim) as that is my phone model.

Hi Vige,
Alas I am not that much of a noob and yes have tried this a few times before and after I upgraded to 4.0.1. I also followed the option that Fairmail offered so I could ‘fix’ my internet, this took me to android internet management but it would not allow me to enter anything so I cannot fix the android side. I assume this is because SFOS blocks this but not being a tech-guru I don’t have a clue?

Hence I confirm I encounter the same bug on a different model. And yes, by XA2 Ultra suffers from the same.

I have a single sim XA2 with SFOS 4.1 and this happens frequently. I don’t remember it happening with SFOS 3.X at all. The only ‘cure’ I have found is to re-boot the phone which will restore network access to Android apps until it happens again. Stopping and starting Aliendalvik from settings didn’t seem to work for me, nor did stopping and starting wifi.

It was weird, in 3.4 it was fine until my phone glitched while I was using Firefox. I thought it was FF that glitched so just shut the app & got on with my day before I realised I wasn’t getting any email notifications. the old chestnut of switching off & on but still no email.
So figured I’d try the waiting up date which has been staring at me for months.
Problem not solved, emails = nada, firefox works just fine for some reason & just tried to check Slack & it too is not connecting to wifi.
For me even after a phone Off / On AlienD. is still dead, nothing responds so I may uninstall as soon as I can locate the instructions again.

I’m in two minds about updating to 4.1 as I’ve heard that a lot of android apps simply aren’t geared for 64bit but that’s a future issue for me to ponder on for a little while (as long as I can stomach the native SF email app.)