SFOS 4.6 (Foreca / MeeCast): How to (re-)enable the weather infos in Events View

This popped up in today’s community meeting. So if you’re trying to use MeeCast and are not seeing weather in the Events View place follow @pvuorela 's instructions and force weather loading.


every month i made a new foreca account to “test” the api, but since yesterday this doesn’t seem to work anymore, i tried to create an additional account, but with that it also doesn’t work. maybe they recognized a pattern and blocked my api calls?

@lakeboy, thanks again for testing. I am pretty sure I now have all issues resolved, as these two tests (“Test 1” and “Test 2”) finally run fine.

I would appreciate, if you or someone else tests “in real life” again (i.e. on a device with SailfishOS 4.6.0 installed), with the packages I recompiled. The command lines below assume you are using an aarch64 device (i.e. an Xperia 10 II or 10 III; for armv7hl and i486 the download paths and RPM file names are slightly different) and that you are starting as a regular user (the dconf command must be executed as a regular user):

dconf reset /desktop/lipstick-jolla-home/force_weather_loading
pkcon remove lipstick-jolla-home-qt5-weather-widget-settings harbour-meecast-event harbour-meecast-daemon harbour-meecast
mkdir foo
cd foo
curl -LO https://repo.sailfishos.org/obs/home:/olf:/MeeCast/4.6_aarch64/aarch64/harbour-meecast-1.1.39-1.2.1.jolla.aarch64.rpm
curl -LO https://repo.sailfishos.org/obs/home:/olf:/MeeCast/4.6_aarch64/aarch64/harbour-meecast-daemon-1.1.39-1.2.1.jolla.aarch64.rpm
curl -LO https://repo.sailfishos.org/obs/home:/olf:/MeeCast/4.6_aarch64/aarch64/harbour-meecast-event-1.1.39-1.2.1.jolla.aarch64.rpm 
pkcon install-local harbour-meecast- harbour-meecast-daemon- harbour-meecast-event-
rm -f harbour-meecast-*
cd ..
rmdir foo

Does MeeCast-EventView now work out of the box?

If so, I will submit these packages to SailfishOS:Chum.

1 Like

For me, after having set up sailfish weather event view, the packages currently in chum work out of the box. I just decided to switch to meecast for eventsview and lockscreen, and both work reliably

Sorry, this is well known, but not at all the requested test, hence not helpful.

Please test by executing every command line provided and report back here.

yes it works with your packages

1 Like

@olf nice work! Yes I can confirm that Event view of Meecast is now working. Nice work!!!
What was the missing step?
Thanks for your persistent work - whilst my home weather source isn’t working, I can follow other cities through other sources.
Happy chappy here. :slight_smile:


Only my blindness and idiocy, due to being too hectic as a result of having only little time for this (which then eats even more time :confounded:).

1 Like

Looks like that was the techical solution :wink:

1 Like

Well, technically it was really just that after spinning this thread of commits (2024-05-25 to 2024-06-21) to develop, implement and rectify multiple times a working approach to automatically (and at the right times) execute the commands Pekka Vuorela provided by the spec file.

1 Like

I really doubt usefulness of those ‘one click installer’ approaches, when 4.6 catastrophically failed one of those (can’t remember if it was chum or storeman) would just not install, so while in theory great, in catastrophe useless as you want to get your system back online and can’t waste time to bug report and wait weeks to get it fixed, search results get polluted by the non-working option (probably openrepos issue) and finding the right rpm to just click/install gets even harder.
Edit: idk maybe for weather it makes sense as you have to issue one command in cli, but for storeman/chum it was always just clicking the right arch rpm, then the maintainers decided to keep rpms in github and only provide failable script for newbies on openrepos, why?

maintainers decided to keep rpms in github

Or maybe this is just for the ‘installers’? Idk, idc, it’s a bit of a mess anyway, finding proper storeman client on storeman and not the installer one is an issue though
Edit2: like seriously, how do you find chum gui if the ‘installer’ fails:

Edit3: here are results for ‘storeman’, the actual rpm nowhere to be seen (I know inapp screenshot is bad but it’s the same on webpage, if installer fails you get a ton of useless crap)

Edit4: oh no, actually the ‘legacy’ is the real one that gets installed by installer if everything works fine? Can’t even tell

@throwaway69, this is absolutely senseless rambling: Not a single aspect of what you wrote is technically correct. Furthermore it is completely off-topic in this thread.

Everything is well documented: You just have to read the OpenRepos pages or READMEs at GitHub, and ultimately it is Open Source Software so you can look at how this works. If you then have a proper suggestion how to improve the SailfishOS:Chum GUI Installer and / or the Storeman Installer, you may open an issue or create a PR at GitHub.

BTW, the installers are there for a reason: Jolla introduces breaking changes with almost every SailfishOS release (see e.g. this thread), hence it is basically impossible to provide a non-trivial software by a single RPM for multiple SailfishOS releases.


RTFM: Reading Thoroughly First is Much advantageous.

P.S.: No bug reports mean no improvements.
Note that such ramblings do not constitute a bug report, because they lack specific information beyond “does not work for me”.


It’s either one-click for newbies, or you have to read 5 pages of documentation and it still fails in the end… Both of my reflashing experiences ended up with looking for just the rpm in the end, the base app hasn’t changed since 2022 it seems, the only thing that’s changed is people need to know that ‘legacy’ means it’s an actual working solution (or maybe following the github tags/releases for the rpm, seems there used to be an even bigger mess with storeman for 2.x, 3.4, <4.2, 4.2+ etc)

1 Like

To state it more bluntly (I hope that reaches you):
Without reading you will not comprehend things and hence continue to be a “newbie”.

[…] and it still fails in the end…

for you is very likely a consequence of not reading and understanding.

If your experience is really caused by a technical issue, you ensure that it persists by rather writing lengthy, incorrect and senseless ramblings instead of being constructive by filing a proper bug report at GitHub, which would have taken less time.

that ‘legacy’ means it’s an actual working solution

Absolutely not: I am surprised to hear that a “legacy” release of Storeman (i.e. written for SailfishOS < 3.1.0 or less, depending on which “legacy” release you use) works on SailfishOS 4.6.0 for basic functionality, but many details and special functions will definitely not work.

But as you …

…, nobody knows (including yourself) what exactly you are talking about or which versions of this software you mean to address.

Without such very basic, specific information your postings will always be useless pieces of shit.


I just make a clean install of SFOS on Xperia 10 III. Then I use the Meecast apps from Chum. All installed without any issues. But the widget failed to activate after reboot and nothing of the other one like lock screen etc. is displayed.

you will still need to follow the instructions from here for now.
This method works a treat

1 Like

Hey guys,

MeeCast app from the Jolla store seems to work again. I was able to choose from different sources and find my location again… xperia 10 ll

i started the app after the last update for the first time today and it worked…


As I said, don’t have time after reflash and 8h of updating jollaC to go on github and waste another hour filling bug reports that will be ignored with: read the docs. Much faster to just grab the relevant rpm from github tags (the whole thing this whole installer was supposed to make easier). Was the same after fresh flash of 4.5 on XIII and upgrade to 4.6, if your installer is not working on freshly flashed devices, I’m afraid it’s not providing the service it was supposed to, maybe too much time spent on 2.x, 3.x etc so no time to test basic functionality on latest versions, maybe someone will just upload the rpms straight to OR so newbies don’t have to navigate github (and yeah your docs don’t even explain that simple fallback onto gh rpms, useless)
Edit: oh wait nvm, storeman installer not working during early access, is working as intended/won’tfix (cBeta in your docs language), lol, carry on, hopefully someone just uploads storeman rpms to openrepos so ppl with failed update experiences can use actual OR to get a working OR client
edit2: and here it is, when most of ppl needing to reinstall storeman are from EA failures, just dump it in 2/3 of the way of 2 pages of important notes and use different terminology (not troubleshooting, not something to clarify right away, background needs a page)

This is automatically done by the current Meecast packages at SailfishOS:Chum, i.e. no manual work is required.

Soon™ this issue will also be resolved by a new package harbour-meecast-eventview (note the addition of “view” to the package name harbour-meecast-event, which will then only support SailfishOS < 4.6.0) at OpenRepos.


I installed Meecast from Chum. And still cannot select country. I write it but then nothing happens.