SFOS 4.5 horrible fingerprint sensitivity (XA2 plus)

HARDWARE: Xperia XA2 plus (H4493)
REGRESSION: probably not (?)


I did a clean install of latest SFOS on my brand new XA2 plus (6GB version, dual sim). I have used the phone with stock android and everything was working ok hardware-wise.

What I noticed immediately after installing is very very slow fingerprint sensor responsiveness or even not being able to register my finger at all. When it is working it takes at least 3 seconds to unlock screen after I place my finger on the sensor.

I have tried to restart the phone, fingerprint service and add the same finger three times and there are no improvements.


Clean install over stock android 8


  1. Clean flash of SOFS
  2. Register fingerprint
  3. Try to use fingerprint sensor to unlock screen


Fingerprint sensor detecting my finger in under a second which is stock behavior on android


Finger not detected or very slow response


None, I didn’t even add my email account nor did I install android support (haven’t bought licence yet)


This is 100% NOT hardware related as I tried to flash stock android back and fingerprint was working fine, then flashed SFOS again and the behavior is the same as reported here

I do not have any H4413 device but an H4113 with
On this phone, unlocking the screen with the touch of a fingertip happens in a fraction of a second.

Stupid question. Are these like the fingerprint sensor in the 10ii. So, built into the button? Those work like crap for me, whereas flat on the back of the phone one’s work well. The 10ii sensor which I’ve trained for two different digits often takes three or 4 swipes and I always forget which direction … on the volla/GS290/GS5 it’s instant. Form factor thing?

No problem on my XA2 Plus (H4413) with fingerprint reader. However, it 's an upgrade from 4.4 not a fresh install.

1 Like

I have just checked on my “regular” XA2 dual sim and fingerprint sensor works ok there, so I guess this affects only XA2 plus - maybe only 6GB models as they are quite rare.

After adding the same finger again (so 4 times in total) and intentionally placing finger “suboptimally” now it is somewhat better, or should I say, at least usable.

Not wishing to be Captain Obvious, but when you set up your fingerprints, did you make sure to move your finger around as much as possible when you calibrated it? Otherwise you only show it one little spot on your finger.

yes, of course. As I said, I spent significant time with stock android and fingerprint sensor worked fine without having to add the same finger 3-4 times. But on SFOS it barely recognizes my finger during fingerprint setup process.