SFOS 4.5 feedback thread

for my Xperia 10III, 4.4 => 4.5 did the most damage of any SFOS upgrade ever.

  • mobile data works randomly, about 25% of the time (it seems the wrong ip -6 route is selected randomly)
  • android support is MUCH worse:
    • some apps dont work (e.g.: element
    • sdcard is randomly mounted or not (storage not found errors occur frequently)
    • storage framework changed or something and now i cant get access to books in coolreader not on sdcard, and sdcard fails to mount half the time
    • CPU usage is 100% for media service for 40+ hours, presumably scanning my sdcard even though i have it marked not to. never happened in 4.4
  • notifications (like SMS alerts) randomly dont happen (restarting ngfd fixes it when it happens, which is often)
  • bluetooth just doesnt work at all. service wont start (havent debugged this one too much yet)

there are a few other problems too, like missing packages and dependencies for things i use, too, but nothing that breaks usability so much as the above 4 problems

Sorry to hear you have a bad experience. For what’s it worth:

  • mobile data works randomly, about 25% of the time (it seems the wrong ip -6 route is selected randomly)

Disable IPv6. You don’t need it. (I know it doesn’t fix the original problem, but it’s a quick workaround till it’s fixed.)

  • SD card problems

10 III has 128 gigabytes with some 90 gigs of space left. Are you sure you need an SD card?

  • bluetooth just doesnt work at all. service wont start (havent debugged this one too much yet)

Install Sailfish Utilities from the store. It has Bluetooth restart. You probably have to restart it once or twice, but it’ll work eventually. Again… till it’s fixed.

Just my two cents. I hope it helps.

1 Like

I hear ngfd I kindly ask you to participate to this thread [][][][] No notification sounds (ringing, SMS, alarm) - #56 by vlagged

1 Like

ah, yep, thats [one of] my bugs alright

thanks for the well-meant reply.

i DO need it tho. my carrier (tmobile) only does MMS over IPv6, and MMS is used extensively where i live (USA)

heh. i have only about 100GB free on my 1TB sdcard and ive been feeling a little nervous about it.

systemctl restart bluetooth does not fix it. nothing ive tried fixes it. does sailfish-utilities do something aside from restarting the service?

1 Like

I don’t know about the Utilities, but @jameson wrote that trying to reset Bluetooth from the Utilities may have an effect. One more idea, have you tried the following commands?

systemctl restart bluetooth
systemctl restart bluebinder

EDIT: fixed a typo

i’ve had the 10iii working for a day now. my impressions:

  1. lovely and fast
  2. most things work great (including all the essential phone things).
  3. element does not work
  4. neither does gps. exactly as incapable of getting a fix as my xa2plus, which is a surprise as i was always told the sfos gps problems were mostly an xa2 thing.


yea, ive done that. also, a restart doesnt fix it either. bluetooth just literally never works ever, it doesnt intermittently go out

1 Like

Just checking, now have you tried restarting Bluetooth service from Sailfish Utilities, like 2-3 times?

Element on my 10mk3 works. I have it installed from AuroraStore.

Is there any indication that the version published on the aurora store is older - explaining why it is failing when sourced from fdroid/aptoide?

F-droid has Element 1.5.18 and Aurora Store has 1.5.22. F-droid has updated the app Jan 11th, just over a month ago, so I’d hardly call that outdated…

1 Like

We have found the reason for this issue. The fix was prepared and is being tested. There is a plan to publish a hotfix.


I like the idea of hot-fixes. Maybe you can do the same with CLAT (Testing CLAT for IPv6-only mobile networks) once it’s finally tested?

so is this looking like a problem that has already been fixed? i.e. we’re just waiting for fdroid/aptoide to update the published version?

none of these versions of element (im.vector.app) works for me: 1.5.18, 1.5.22, 1.4.20.
all 3 work on SFOS 4.4 on my 10III.

the difference may be whether you have a google play services framework or not (opengapps/etc); i do not.

1 Like

Mebay check with the appsupport logcat what would be wrong can be it uses also the /data/0/ path same as my bank app do…

For those with the Xperia 10 III like me, I really think this phone works best with a wipe and a clean install. Normally I upgrade, but I feel like there has been enough tweaks and changes under the hood where going through the trouble of a do over is worthwhile.

For reference, I’m from the US and I use T-Mobile.

My GPS works great and hasn’t goofed up on me yet. I have “GPS positioning” enabled after turning on “custom settings” under location in settings. Previously I had “high-accuracy positioning” enabled and for some reason, it was buggy as all get out.

For my cellular network settings, please consider the following settings if you’re on T-Mobile in the USA:

Connection Name: T-Mobile
Access Point Name: epc.tmobile.com
Protocol: IPv6
Authentication: None

Connection Name: T-Mobile MMS
Access Point Name: epc.tmobile.com
Protocol: IPv6
Authentication: None
Leave proxy address and port fields blank
MMS message center:

After all this configuration, phone calls are rock solid, cellular data works like a charm, and regular SMS is flawless. MMS however only appears to work in one direction, receiving MMS. I’m unable to send MMS on Sailfish OS for whatever reason. If anyone here happens to know why that’s the case, I’m happy to make adjustments to my configuration. That being said, this is probably as good as it’s going to get for me.

1 Like

I got mms working on T-Mobile (Denver CO) my settings differ somewhat:
Access point: fast.t-mobile.com
Message center: http://mms.msg.eng.t-mobile.com/mms/wapenc
Besides that it’s the same.

The video playback was fixed to the OS release