SFOS 4.5 feedback thread

I’ve found two issues after the upgrade. The upgrade it self went without any problems.

My account for mail using Microsoft Exchange initially had a wrong password after the upgrade. The password was set to ‘default’, but changing that to what it should be didn’t help. So reinstalling did make it work for about a day or say… most likely it stopped working after I needed the reboot the phone.

Also some andriod app issue eat all my mobile data which was when I found out that the second sim couldn’t make a data/internet connection. Swapping this to first slot made it work, but swapping it back to the second slot still didn’t work… I didn’t have this problem before the upgrade so…

Any help/idea about how to fix the Microsoft Exchange and/or mobile data issue on the second sim would be welcome.

Two design related irks in the 4.5 release (after using it for 5 mins)

Both related to long reaches.

The little keyboard icon on the top left corner of the password screen (after boot) and the new Calendar week view change again on the top left.

They were placed exactly on the opposite side of where the hand of a user usally is making them impossible to reach with one hand.

The little keyboard could have been placed under the numbers in the center and the week view changer under the date numbers on the left side. They would be MUCH easier to reach this way.


I see this update brought masking for Android app icons, to make them fit better with the Sailfish icons. However it seems to mostly use a teardrop shape with a corner at the lower right. I would like to use other shapes for some apps. Is it possible to customize them?


Experia XA2 plus.
Trouble in internet connection with Android apps while connection works with native apps, “Internet connection not available” reboots needed to have a working connection.

Hours of trying the GUI update wouldn’t work, so, against the prompts to avoid CLI updates, I started one and saw an error message there:

error: unpacking of archive failed on file /sdcard: cpio: File from package already exists as a directory in system

I had an empty directory at /sdcard which apparently interfered with the update. Nothing should ever just assume that a file or directory name isn’t already taken …

@jovirkku : (SFOS 4.5+, host /etc/hosts in AD/AAS) Instead of changing system files like aliendalvik-prepare.service, is there another possibility to add lxc.mount.entry = /etc/hosts system/etc/hosts none bind,create=file 0 0 to AD/AAS? Is Jolla going to use alien-generate-extra-config.sh in the future or can we users use that?
(BTW, why are you testing for this script with “-f” instead of “-x” when you then want to execute the script w.o. prepending “sh”??)

1 Like

for my Xperia 10III, 4.4 => 4.5 did the most damage of any SFOS upgrade ever.

  • mobile data works randomly, about 25% of the time (it seems the wrong ip -6 route is selected randomly)
  • android support is MUCH worse:
    • some apps dont work (e.g.: element
    • sdcard is randomly mounted or not (storage not found errors occur frequently)
    • storage framework changed or something and now i cant get access to books in coolreader not on sdcard, and sdcard fails to mount half the time
    • CPU usage is 100% for media service for 40+ hours, presumably scanning my sdcard even though i have it marked not to. never happened in 4.4
  • notifications (like SMS alerts) randomly dont happen (restarting ngfd fixes it when it happens, which is often)
  • bluetooth just doesnt work at all. service wont start (havent debugged this one too much yet)

there are a few other problems too, like missing packages and dependencies for things i use, too, but nothing that breaks usability so much as the above 4 problems

Sorry to hear you have a bad experience. For what’s it worth:

  • mobile data works randomly, about 25% of the time (it seems the wrong ip -6 route is selected randomly)

Disable IPv6. You don’t need it. (I know it doesn’t fix the original problem, but it’s a quick workaround till it’s fixed.)

  • SD card problems

10 III has 128 gigabytes with some 90 gigs of space left. Are you sure you need an SD card?

  • bluetooth just doesnt work at all. service wont start (havent debugged this one too much yet)

Install Sailfish Utilities from the store. It has Bluetooth restart. You probably have to restart it once or twice, but it’ll work eventually. Again… till it’s fixed.

Just my two cents. I hope it helps.

1 Like

I hear ngfd I kindly ask you to participate to this thread [][][][] No notification sounds (ringing, SMS, alarm) - #56 by vlagged

1 Like

ah, yep, thats [one of] my bugs alright

thanks for the well-meant reply.

i DO need it tho. my carrier (tmobile) only does MMS over IPv6, and MMS is used extensively where i live (USA)

heh. i have only about 100GB free on my 1TB sdcard and ive been feeling a little nervous about it.

systemctl restart bluetooth does not fix it. nothing ive tried fixes it. does sailfish-utilities do something aside from restarting the service?

1 Like

I don’t know about the Utilities, but @jameson wrote that trying to reset Bluetooth from the Utilities may have an effect. One more idea, have you tried the following commands?

systemctl restart bluetooth
systemctl restart bluebinder

EDIT: fixed a typo

i’ve had the 10iii working for a day now. my impressions:

  1. lovely and fast
  2. most things work great (including all the essential phone things).
  3. element does not work
  4. neither does gps. exactly as incapable of getting a fix as my xa2plus, which is a surprise as i was always told the sfos gps problems were mostly an xa2 thing.


yea, ive done that. also, a restart doesnt fix it either. bluetooth just literally never works ever, it doesnt intermittently go out

1 Like

Just checking, now have you tried restarting Bluetooth service from Sailfish Utilities, like 2-3 times?

Element on my 10mk3 works. I have it installed from AuroraStore.

Is there any indication that the version published on the aurora store is older - explaining why it is failing when sourced from fdroid/aptoide?

F-droid has Element 1.5.18 and Aurora Store has 1.5.22. F-droid has updated the app Jan 11th, just over a month ago, so I’d hardly call that outdated…

1 Like

We have found the reason for this issue. The fix was prepared and is being tested. There is a plan to publish a hotfix.


I like the idea of hot-fixes. Maybe you can do the same with CLAT (Testing CLAT for IPv6-only mobile networks) once it’s finally tested?