(sfdk): Unable to init new project

Problem Description:

I have now installed sfdk using the Docker Build Engine on two different computers, but on neither of them am I able to initialize a new Qt Quick application. The same problem occurs on both computers.

Problem Details:

  • Computer 1:

    • Operating System: Ubuntu 23.04
    • Docker Version: Docker desktop 4.19.0 (106363)
    • Sailfish SDK Version: 3.10.4
  • Computer 2:

    • Operating System: Ubuntu 20.04 (clean installation)
    • Docker Version: Docker desktop 4.19.0 (106363)
    • Sailfish SDK Version: 3.10.4
  • Docker Functionality: Docker works fine otherwise, and I have successfully used other Docker commands.

  • Reproducing the Problem:

    • I installed Sailfish SDK following the instructions on the page: Installation | Sailfish OS Documentation
      • Workspace folder (default): ~
      • Sailfish SDK installed location (default): ~/SailfishOS
    • I created a new directory at /home/myusername/sf-dev/test.
    • I navigated to the /home/myusername/sf-dev/test directory.
    • I tried to initialize a new Qt Quick application:
      • Input: ~/sf-dev/test$ sfdk init -t qtquick2app
      • Output: “install: cannot create regular file ‘./test.pro’: Invalid argument”

Additional Information:

If available, I will try to obtain a more detailed error message from the sfdk init -t qtquick2app command. I have attempted to resolve the issue by reinstalling Sailfish SDK and Docker desktop. Finally, I even tried a fresh installation of the recommended Ubuntu version by Jolla (Computer 2).

Thank you in advance for your assistance.

Not that it adds very much; but it works fine for me.
Same version sfdk, Linux Mint 21.1, so pretty similar OS.
And you have of course ensured write permissions…

That is really weird. There isn’t really any magic happening there, the SDK is just trying to create the file.

Now I’m wondering if you have installed docker in rootless mode (Run the Docker daemon as a non-root user (Rootless mode) | Docker Documentation) ? I could imagine that rootless mode could have that kind of effect. We specifically advice against using rootless mode in the install instructions: Installation | Sailfish OS Documentation

Thank you for your help. I got it working now. For some reason I hadn’t tried the only Docker engine version of the Docker that I can just install with sudo apt install docker.io Instead, on my every attempt I installed the Docker desktop version of the Docker. I am not sure whether Docker desktop installs in rootless mode but I found that it installed docker-ce-rootless-extras -package. I tried to follow docker’s rootless mode uninstallation guide Run the Docker daemon as a non-root user (Rootless mode) | Docker Documentation but still no luck with Docker desktop. So my question is, does Sailfish SDK support Docker desktop? Either way I am happy to use just the Docker engine to get things working. Still, it would be nice to able use Docker desktop on Linux also.