SDK - Same error building on Emulator

Sometimes I need a bigger, clearer view when developing an app, so I use Emulator in the SDK, but not matter which project i try to run in emulator, I get this same error message and the build/install fails;

    14:06:54: Starting: "C:\SailfishOS\bin\sfdk.exe" -c "device=Sailfish OS Emulator" deploy -- 
    sfdk: [I] Options from environment: -c target=SailfishOS-
    NOTICE: Using the 'SailfishOS-' snapshot of the build target
    sending incremental file list

    sent 218,165 bytes  received 35 bytes  436,400.00 bytes/sec
    total size is 218,001  speedup is 1.00
    Installing harbour-bmw-e46-0.1-1.i486.rpm
    Please confirm installation on device.
    harbour-bmw-e46: [PK_TMP_DIR|dir:/var/tmp/TmpDir.JPDMkY] Repository already exists. (code: 4)
    Installation failed
    Deploy failed
    14:07:05: The process "C:\SailfishOS\bin\sfdk.exe" exited with code 1.
    Error while building/deploying project harbour-bmw-e46 (kit: SailfishOS- (in Sailfish 
    SDK Build Engine))
    When executing step "RPM Deploy"
    14:07:05: Elapsed time: 00:44.

What do I need to do here?, where is PK_TMP_DIR…?, any clues please, I need to see details that my 52 year old eyes cannot see on my device (Sony Xperia 10ii).

That happens with every project? My first guess is that there’s something funny on your emulator. You could try resetting it back to a snapshot.

Yes, every project, they all build on the device but no in emulator.

Okay, so I have just reset emulator and now the virtual machine does not start…“Connecting to the “SailfishOS-4.4-0.58” virtual machine”…it just sits there (this is not uncommon and is the start of less and less things working until I reinstall SDK…this is happening at least once a week. If i were to report ALL the problems I encounter with SDK, it would be the only thing I ever post.

It’s been a good 4 minutes and still I am waiting for the above connection…time to reinstall, {{{sigh}}}.

Before you reinstall, it might just be worth it to try to restart the vm. Perhaps a few times.

Right, I’ ve now actually got my app to run on emulator, for which I have selected to view in landscape, but it is virtually unusable, I’ll explain why in another post.

Perhaps a few times?, yes you are correct, it took a few starts and now its loaded in emulator…wow, what a mess the emulator is when in landscape…console is giving an error as well;

[W] unknown:11 - file:///usr/lib/qt5/qml/Sailfish/Silica/private/CoverWindow.qml:11: ReferenceError: 
Config is not defined

I’ll make another post about these problems. I guess not many users are devving apps in landscape.

Thanks for your input @vige

Windows 10 + hyper-v + VirtualBox + 32 bit linux as a guest is not a great combination. Unfortunately it’s all we’ve got. If you don’t need hyper-v for anything you can disable it and it will help a lot.

You are probably right about not many developing apps in landscape mode with the emulator. So your feedback will be appreciated, thanks already!

I had to google hyper-v and upon checking it out, hyper-v is already disabled (unticked).