[SDK][i486][Dual Screen] Emulator keeps rebooting when on dual screen



SFOS Emulator keeps rebooting when deploying an RPM file.


Have a dual screen.


  1. Connect to a dual screen
  2. Open SDK
  3. Select an existing or a new project
  4. In the “Project Settings” > “Build & Run”, make sure to have a “SailfishOS- (in Sailfish SDK Build Engine)” kit.
  5. Run the project with that kit and deploy the project as an RMP package (doesn’t mater if it’s a Release or Debug build)
  6. Wait for the emulator/VM to boot, unlock the screen. (sometimes it takes a couple seconds to reboot, less than 10)


Either an error or a screen booting and working. Currently the only errors I get are:

from the “General Messages” tab

Error connecting to "SailfishOS-" virtual machine: SSH conection with virtual machine "SailfishOS-" has been lost: SSH connection failure.
Warning: Permanently added '[]:2223' (ED25519) to the list of known hosts.
Connection to closed by remote host.

and from the “Compile Output” tab

11:07:15: The process "/home/jo/SailfishOS/bin/sfdk" exited normally.
11:07:15: Deploying RPM package...
11:07:15: Starting: "/home/jo/SailfishOS/bin/sfdk" -c 'device=Sailfish OS Emulator' deploy --sdk
sfdk: [I] Options from environment: -c target=SailfishOS-
NOTICE: Using the 'SailfishOS-' snapshot of the build target
sfdk: [I] Starting the emulator…
Error running command on the build engine: Remote process crashed.
11:07:23: The process "/home/jo/SailfishOS/bin/sfdk" crashed.
11:07:23: Canceled build/deployment.
11:07:23: Elapsed time: 01:01.


An emulator that reboots every 2 seconds, not an exaggeration.




Worked a week ago. No changes to the SDK were provided. Re-installing the SDK doesn’t solve the issue. There are no SSH related rules on my computer.

See below my build options for that project. All projects are impacted, even default ones like Component Gallery.

This issue happens also when booting the simulator directly from the Virtual Box without the SDK running. But I’m unable to find any error in the Virtual Box logs. I also tried booting with different graphic controllers : VBoxVGA (default) and VBoxSVGA are the only one displaying the OS and VMSVGA halts at the boot.

Did you receive any updates to VirtualBox recently? Can you try to downgrade to some older version? It has happened a few times already, that an update to VirtualBox broke the VMs on some systems.

Well maybe I had an update in between my uses but can’t remember. I can’t downgrade my VB version because I’m using Debian Buster with a v 5.10 kernel and the previous versions of VB had an issue with that version until the latest update. Regardless, I re-installed (after deep cleaning) VB using Oracle’s repository and now its working fine (no add-ons were installed).

Currently VB on version: 6.1.36 r152435 (Qt5.15.2)

This issue is now solved for me so I’ll market the subject as solved too.