SDK error: module "QtLocation" is not installed

Hi, my app used to run correctly in the SDK, but I’ve tried recently and I now get the following error when trying to display a map:

PageStack.js:483: Error: Error while loading page: /path/to/InteractiveMap.qml:3 module “QtLocation” is not installed

If I try to list the installed packages on the VM, it seems correctly installed (I have qt5-qtdeclarative-import-location declared in my .yaml):

Installed qt5-qtlocation-5.2.1+git32-1.5.3.jolla.i486 (installed) The QtLocation library

Also, it work without any issue on an actual phone.
Any idea what I’m missing? What has changed since a year?
Thanks in advance!

Could you give us a link to your project, or better yet: Could you create a minimal test case which used to work but no longer does? I believe.

After clicking on “Stations Map” the map page appears on the screen, keeps loading, and in the log I see

[W] unknown:44 - file:///usr/share/harbour-bikeme/qml/pages/InteractiveMap.qml:44:9: QML Map: Error: Plugin does not support mapping.
Error message: Qt Location requires app_id and app_code parameters.
Please register at to get your personal application credentials.

So I assume the module is correctly loaded.

Try to factory reset the emulator using Options > Sailfish OS > Emulator > Factory Reset... under Qt Creator.

1 Like

Yes that’s this app, thanks for checking :slightly_smiling_face:
A factory reset solved the issue indeed, I wasn’t aware of this option, thank you!