SDK doesnt support modern SSL stacks

Trying to install the SF SDK on Debian buster and i’m running into SSL compatibility issues (i.e needs 1.0.x but the current available version in the repo is 1.1)

I’ve read elsewhere that you’re aware and dont currently support 1.1 which means you dont support modern Linux distributions.

I’m having this issue with both the 3.2 stable and 3.3 ea SDKs which suggests you’re not treating this as a priority.

You’re only hurting adoption of the platform by making it as difficult as possible to allow devs to actually build software and invest time into Sailfish. Why raise the barrier to entry for devs??

Please rectify as soon as possible.

From the latest community meeting: https://irclogs.sailfishos.org/meetings/sailfishos-meeting/2020/sailfishos-meeting.2020-10-29-08.00.log.html#l-246

-- the next release will have OpenSSL 1.1.1h

Which can be also seen here: https://git.sailfishos.org/mer-core/openssl

2 Likes

Okay fantastic, thanks for letting me know.

Really looking forward to developing stuff for SF (Think its time SF got a proper Spotify client) but having not touched the IDE for a number of years this threw me for a loop, i’ll wait till the next release.

2 Likes

This has nothing to do with the issue of the SDK installer. Changing the ssl library which is used by the installer does not happen by simply updating the library, it’s a lot more complex than that. We are working on it, but I won’t give any promises on when the work will be finished.

In the meantime, installing on Debian Buster is possible by installing the library from an older Debian release first. You can download it directly from the repositories: http://security.debian.org/debian-security/pool/updates/main/o/openssl1.0/libssl1.0.2_1.0.2u-1~deb9u2_amd64.deb

1 Like

Ah, I misunderstood the question. Sorry about that. Now that I read it again, the question clearly has nothing to do with what Sailfish OS contains and everything to do with SDK.