SDK doesnt open on wayland session

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): Linux Host

DESCRIPTION:

The .desktop file for the Sailfish SDK uses the command line -name Sailfish-SDK … presumably to set the window title. I think this param must only work on X11, as the application fails to start on a wayland session. Running in konsole gives this:
piggz@localhost ~ $ ./sdks/SailfishOS/bin/qtcreator -name Sailfish-SDK
Unknown option -name

PRECONDITIONS:

Wayland session

STEPS TO REPRODUCE:

  1. Open Sailfish SDK from the menu

EXPECTED RESULT:

SDK Opens

ACTUAL RESULT:

Nothing happens

1 Like

VIrtualbox doesn’t work on wayland -last time i tried at least-. You need to use XWayland.

apart from the start issue, which i resolve by editing the menu entry, everything else seems to work ok

Thanks for the report, I filed this in our internal bug tracker

Another issue with the SDK on KDE, which could potentially go on the same report. If using a global menu bar, then qtcreator doesnt show a menu bar at all!
setting QTCREATOR_DISABLE_NATIVE_MENUBAR=1 “fixes” it by showing the menu in the app as a normal bar. I use the following entry in the .desktop file
env QTCREATOR_DISABLE_NATIVE_MENUBAR=1 /home/piggz/sdks/SailfishOS/bin/qtcreator
to fix both bugs

1 Like