[SDK 3.4.9] DNS queries don't work OOTB

I downloaded SailfishSDK-3.4.9-linux64-offline.run, installed it and tried to compile my own creation with it. It trigger a package installation, which naturally requires Internet connectivity, which requires DNS queries to work. All I get is an error message in Qt SDK saying that the build engine could not resolve releases.jolla.com in the first place. (I fixed it, so the exact error message is gone.)

I root-SSH’d into the build engine and sure enough, I couldn’t ping any host that required a DNS query. responded OK, though.

After some digging I found out that /etc/resolv.conf only contained It turned out that I had to manually add a DNS server to connman like this (sanitized):

# connmanctl services
* O Wired                ethernet_112233aabbcc_cable //LAN adapter
* R Wired                ethernet_aabbcc112233_cable //SDK adapter
# connmanctl config ethernet_112233aabbcc_cable --nameservers

After rebooting the build engine for good measure, the targets can now install their packages.

My LAN seems to be OK and my host computer has a working Internet connectivity. Is this just some weird quirk of the offline image, or is there a bug in the build engine?

It shouldn’t make any difference whether you use the offline or online installer. It might be a bug in the SDK, but more information is needed in order to figure it out. Which Linux distribution are you using? Are you using Docker or VirtualBox based build engine? Which version of Docker/VirtualBox?

I tested this with Ubuntu 20.04, and sure enough, the SDK works as expected.

Due to unrelated reasons (fix your kernel modules, Realtek) my Manjaro station is without Internet connectivity, which has halted this and many other things. I have come back at this at a later time.