SD card write permission for Android

I synchronize a directory with photos onto my phone using syncthing, it is stored on the SD card.
I would like to use Android application F-Stop to manage them but even though I granted it permission for the folder it still cannot change any file.

This is what happens when the files are owned by “defaultuser” (straight from syncthing) after I try to change the metadata. The photo is renamed but nothing is changed in it (and F-Stop loses track of it, reporting that it is missing):

-rw-rw-r-- 1 defaultu defaultu 1493553 Mar 11 19:40 2023_0311_19393900.jpg90846cf0-3ac9-4505-a3be-0061b935c1dc

I tried to chown to media_rw, the same thing happens, nothing is changed inside a file:

-rw-rw-r-- 1 media_rw media_rw 1493553 Mar 11 19:40 2023_0311_19393900.jpgc0087a5d-04a4-4b08-99d8-c26ec1ec6bb5

chmod ugo+rw does not help either.

Kindly advise me how to fix this.

| Sailfish OS (Struven ketju)

This is what the program asks for:

It is not possible to grant the permission in the root of the SD card however. I have to enter into my photo directory and only then the button to grant permission appears.

I just tried the trick of bind mounting the SD card directory to the internal storage (~/android_storage/FUJIFILM.REMOTE) and the program can successfully change the files there it seems. Nonetheless I am not celebrating yet: I did the same on previous version of SFOS and it did work at first. After the first and subsequent reboots however, I would bind mount the directory again but it would no longer work…
I am still looking for a real solution.