Screenshots not shown in android apps

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.2.0.21
HARDWARE (XA2, X10, X10 II, …): X10II
UI LANGUAGE: Finnish
REGRESSION: (compared to previous public release: Yes, No, ?): ?, have not noticed/tested before

DESCRIPTION:

Screenshots taken show in gallery app but when trying to share them with Whatsapp or Signal the images are not found anywhere.

PRECONDITIONS:

?

STEPS TO REPRODUCE:

  1. Take screenshot by pressing volume up and volume down buttons simultaneously
  2. View taken screenshot in gallery
  3. Try to share image with Whatsapp or Signal

EXPECTED RESULT:

Find the image and to be able to share it with Whatsapp or Signal

ACTUAL RESULT:

Image can not be found in Android apps (Whatsapp or Signal) but one can see them in file manager or gallery. There is only one picture in the screenshots folder in gallery even though there should be more.

ADDITIONAL INFORMATION:

1 Like

I can see the screenshots and other pictures on my X10ii when going to send an image with WhatsApp. The latest screenshots are in β€œAll media” (right at the top of the view) and also further down in the Screenshots folder.

The same worked on Telegram, too.

Would the restart of Android App Support or of the whole phone help?

I tried to find the reason for my problem and here is a somewhat strange fix to the issue. It was indeed something to do with android support but there were some other unidentified issues lying on the bottom:

  1. Take a screenshot
  2. Check that I can see it in the gallery under the screenshot folder
  3. Try to share it with Whatsapp β†’ FAILURE, picture is not shown

  1. Reboot the phone and I can now see the image with Whatsapp
  2. Take a new screenshot and repeat the process β†’ SUCESS !!
  3. Take another new screenshot and repeat the process β†’ FAILURE again, I can see the previous shot but the new one is missing.
  4. Try the steps 4 - 6 again and the same thing happened; I can see the 1st taken screenshot after the reboot but not the later ones.

  1. Try to restart the android support β†’ FAILURE, my phone claims it is not installed (=cannot locate it from the settings) at all desipite the fact that I have many android apps installed and I can install more of them without problems
  2. Go to the jolla store and verify that I do not have android support installed
  3. Install android support
  4. Take a screenshot again and repeat the process β†’ FAILURE, the new image is not shown
  5. Restart android support and repeat the process β†’ SUCCESS!!
  6. Try again β†’ SUCCESS!!