Screenshot not working

I installed screenshot from store but it doesn’t work.
I get an error message that translates to “screenshot not allowed by the device security settings” when i try to take a screenshot.
I then tried ScreenTapShot2 but i got the same message.
I don’t know what settings i need to change.

1 Like

Same here

  • 20 characters.

Screenshot has had the security problem for a long time, but ScreenTapShot2 should be working. Works at least in my X10.
Try contacting @coderus in Storeman. Jolla store doesn’t email comments to the program author.

2 Likes

You can also use the built-in screenshot function: Press Volume-Up and Volume-Down at the same time.

6 Likes

I will assume you are using a Sony device?, I’m still using the original Jolla device, to take a screenshot, I press on Vol + and Vol - at the same time, this takes a little practice though. I’m naturally assuming that the same applies to the Sony devices running SailfishOS, but I could well be wrong…looks like @nephros beat me to it :smiley:

2 Likes

Pressing both Volume-Up and Volume-Down at the same time worked :smiley:
I didn’t know there’s a built in function for taking screenshots, thanks for the help.

Just to confirm, yes it also applies to Xperia devices.

1 Like

I use an Sony Xperia XA2 plus.

Be careful when using the Volume buttons for screenshots with an Xperia X. Mine seem to be “broken” (and I guess it’s because of a few screenshots): sometimes it randomly changes the volume when I shake my phone.

ScreenTapShot2 works for me, though.

2 Likes

Try to install Screenshot2 from Openrepos (https://openrepos.net/content/coderus/screentapshot2), it is a more up to date version, it works perfect in my Xperia XA2.

1 Like