SailfishOS, catastrophic error, does not start after T&C

Sailfish OS Sony xperia xa2 single sim, suddenly crashed without warning. After a restart and unlock you suddenly have to confirm the terms and conditions, if you do that, Sailfish os starts but only 20 seconds later you have to confirm the terms and conditions again and after the 4th time SailfishOS is completely dead. After a forced restart, the same thing happens.

Is there any other way to save this apart from reinstalling?

Does anyone know of such an error?

Makes me think of this:

Ok thanks. This is the bug. Not good at all. It happens like a flash out of the sky. I will not create a multiuser again. I have backups though. But the last one is already 1 month old. :frowning:

Now I can reinstall my phone :frowning:

Has a patch been released from Jolla yet?

Is there still data on the phone, or is there only what is on the SD card?

Alas yes, it seems to be here since a while.
(That was reported in may 2022 in the mentioned thread)

I recall something like having been able to recover the secondary user data once.
I plugged the phone and booted into recovery mode and unlocked /home.
But this chance may depend on which way you were being switching user when it happened.

I dont came in the recovery mod. I us this guide. From jolla i cant download my version. I can download the newest version of my phone. This version i downloaded.

The blue LED came, i can send fastboot boot hybris-boot.img, the phone bootet, but i don`t see “RECOVERY: Connect USB cable and open telnet to address” i see a white screen with the sony logo. What make i wrong?

Hmm, normally, the black screen with the ip address comes by itself just after the white one with the sony logo.
Maybe try another cable on another USB port.
If you have an USB2 hub, try it too.

I can’t get any further. In the meantime I have found the USB HUB. With or without USB HUB, only the following happens. Also no matter which USB port I take. I send

fastboot boot hybris-boot.img
Sending ‘boot.img’ (18696 KB) OKAY [ 25.334s]
Booting OKAY [ 5.136s]
Finished. Total time: 30.486s

after that the phone restarts. About 10 seconds the Sony logo is visible, then briefly the charging icon that you see when the phone is off. Then the LED is briefly to see red and I can, if I want, that repeat again and again.

I have tried it with version, and more versions I do not have on the hard drive.

Does anyone else have any ideas? Otherwise, can I send the phone to Jolla so they can fix it? After all, this is not my fault but Jolla’s. At the moment I only have a paperweight lying here.

For booting into the recovery mode there’s the hybris-recovery.img image, as I understand it.

1 Like

I just tried, after 3 attempts it worked. I was blind, thank you.

1 Like

The home folder is deleted by the BUG. I do not find it funny. I want to reinstall now. But for this I need the unlock code from Sony. I have never noted the IMEI number. I bought the phone with preinstalled SailfishOS system. On the SINM card holder is not printed as on the 10 II and 10 III. How do I find the IMEI number now?

You don’t need the code from Sony. Once unlocked, you can reflash SFOS as often you want.

edit: But you will need your Jolla account credentials from the old SFOS installation you deleted now. After installing SFOS new, you’ll be asked for creating a new Jolla account or enter credentials of an existing one. Choose ‘existing Jolla account’, then you can also re-install Android support and the other licenced stuff.

I wanted to install the latest version, because so far the root directory is limited to 2 GB and with a new installation is immediately raised to 4 GB. For this I would need the IMEI No. otherwise I get the following output

bash ./
Flash utility v1.2
Detected Linux
Searching device to flash…
Found H3113, serial:CQ300043MN, baseband:1311-2845_50.1.A.13.123, bootloader:1310-0301_X_Boot_SDM630_LA1.0_O_123
Found matching device with serial CQ300043MN
Fastboot command: fastboot -s CQ300043MN
fastboot -s CQ300043MN getvar secure
secure: no
The supported Sony Vendor partition image wasn’t found in the current directory.
Please download it from
Ensure you download the supported version of the image found under:
“Software binaries for AOSP Oreo (Android 8.1) - Kernel 4.4 - Nile”
and unzip it into this directory.
Note: information on which versions are supported is written in our Sailfish X
installation instructions online Sailfish X Installation Instructions - Jolla

I checked now for interest, and can download it without any questions from the SONY site.

Its near the bottom,
Software binaries for AOSP Oreo (Android 8.1) – Kernel 4.4 – Nile (latest) March 5, 2019 87 MB


Click Download zip, then the SHA sum page comes, then click download, accept the disclaimer/EULA, download 87 MB and thats it.

1 Like

OK, Thanks. That was it.

Normally, there is a small white plasticboard that you can slip out, near the SIM and Usd holders.