Sailfish x download

Hi, has anyone had any problems downloading the sailfish OS?
I currently already have two licenses and just purchased a third for a 10 plus. but when I try to download it never goes through. The best that I’ve gotten is about 95% and then it fails and says network interruption and to resume download. When I resume it immediately fails and says interrupted forbidden.

Any help would be appreciated.

Just tried. Works for me.

What says that? It doesn’t sound like something a browser would say…

That’s probably a feature of the server to make links personal and time-limited.

Are you downloading really slowly or something?

yes its going very slow. its taking almost an hour and change to get to that point.

i think that i will plug directly up to the router and try it instead of using the wifi.

I tried some hours ago and it worked.
Just to be sure, what is the URL you are using?
I used:

Or, if it is a browser problem, you can try with wget:

  • Begin the download with the browser
  • Go to tools > downloads
  • Right-click on your download and copy the URL
  • in a terminal window, run wget "your_url_pasted_between_quotes"

Problem solved. Turns out that the browser I was using is moving very slow. I realized it after I plugged directly to the router where I did a speed test and saw how slow it was.