Sailfish SDK Virtual Machine doesn't run (kernel panic)

My 64 bit machine is equipped with an intel pentium B950 processor, which doesn’t support intel virtualization technology (see
For this reason, it has given me a lot of pains with virtual machines in the past; I was able to run some though (especially 32 bit ones, 64 bit aren’t going to work).
I wanted to start playing with apps developement, so I installed the SDK and tried to run the VM… this is what happens

It gives me kernel panic and it gets stuck there, not connecting to the VM.
Any ideas on how to solve? Or my processor is simply out of capability for the SDK?
PS: I’m on kubuntu 20.04

Maybe try Docker for building, and just use a phone for testing the apps?
I stopped using the emulator a long time ago, don’t even remember why, and have never thought of moving back.

1 Like

I have never used the emulator. But: are you able to change/edit the kernel boot parameters (of the emulator VM, not the host machine)?

If yes, maybe try turning off cpu idling by giving the or intel_idle.max_cstate=1 or intel_idle.max_cstate=0 kernel parameters.

I’m using (SDK is using) Virtualbox, I couldn’t find where to set those parameters: someone knows how?
I found in the various tabs how to diable VT-x support in the virtual machine, but that changed nothing.

When you install the SDK, there is an option to use Docker instead… The integration is just as good, and it is just slightly less stable. Wouldn’t it work for you?

It’s not in VBox settings, it’s the boot parameters of the kernel inside the vm image, called by its bootloader. How to set/change them depends on the bootloader used and its config.

Thank you so much, I tried right now and it works!
I’ll leave the description to own benefit anyone having my issue:

  • While the virtual machine is booting, press “ESC”;
  • The bootloader screen will appear “Welcome to MerDevice! Press TAB to enter options”, so press TAB;
  • At the end of the options list, add or intel_idle.max_cstate=0 (those only worked for me) and press ENTER.
    The only annoying thing is that the VM is very slow, but ok better than nothing!
    Thank you everyone.
1 Like