Sailfish OS Emulator fails to load Time and Date page in Settings

With the the latest SDK on Ubuntu I get a ‘Page loading failed’ when trying to change the Time and Date for the Emulator.

Any ideas on how to fix this?

sfdk emulator exec sudo pkcon install nemo-qml-plugin-contextkit-qt5

@toner_cloud - same here on Windows 7

@vige - where do we insert that code snippet?, apologies, I asked this before but don’t recall the answer

sfdk is the command line utility that comes with the SDK. You can find it in the bin directory of your SDK installation. So you don’t insert that anywhere, it’s a command that you run :slight_smile:

Thanks, sorry, poor choice of words!

I got an error when running the code;

 Fatal error: nemo-qml-plugin-contextkit-qt5-1.1.10-1.1.1.jolla.i486
 5bluezqt-bluez5-declarative, but this requirement cannot be provided

Maybe sfdk emulator exec sudo pkcon refresh will help with that

Nope. Still the same.

1 Like

Same, pkcon refresh made no difference.

I deleted everything and started again with a fresh install. This time I made a point of selecting the same emulator version as that of the installer, 3.2.something or other and now it works and I can set the time correctly to my home location and not Finland.