Sailfish Browser - no internet connection 'Server not found' - but internet is online and work with other apps and Android Browser

REPRODUCIBILITY (% or how often): 100% since yesterday’s restart
BUILD ID = OS VERSION (Settings > About product): 4.3.0
HARDWARE (XA2, X10, X10 II, …): XA2 Plus
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): ?

DESCRIPTION: Sailfish Browser has a problem loading any website. Always shows server not found. Same on Wifi and 4G network. Android Browser work fine. Internet is connected. Every app with internet works fine.
Problem starts yesterday after installing Yottagram and the call plugin and uninstalling fernschreiber. After the system restart the Bug was there.

PRECONDITIONS: Sailfish Browser was working without problems

STEPS TO REPRODUCE:

  1. uninstall the new installed software again and restart the phone many times, but nothing changed.

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

2 Likes

in Crest app (under show all processes) kill the process booster-browser —application=sailfish-browser

after that the browser should normally connect to internet.

5 Likes

solved. Great forum. thank you very much Kuba77. your solution with killing the booster browser process worked for me.

I have since yesterday suddenly the same problem. Some Sailfish apps have no internet connection anymore, e.g. the browser, tooter or the weather app. Others, like Storeman, Squeezer or all Android apps have internet.
Ping to the internet works. The routes are the right ones.

Killing the process booster-browser -application=sailfish-browser does not solve it.

What else could I do?

Hi, had the same issue like you. Found the solution in other thread. The Problem seems to be caused by dnsmasq. You can remove it and then rebbot the device. After that it should work.
How to remove dnsmasq: Go to terminal and type: pkcon remove dnsmasq
After that reboot the phone and it should work. Cheers

1 Like

Oh, thank you, your tip solved it. I also think I know the cause. Because when dnsmasq was removed, waydroid was also removed due to dependency. I had installed waydroid for testing. With it, dnsmasq was also installed and it no longer worked.
Thanks again.

As a reference for others here is the dnsmasq discussion thread.

2 Likes

As of 13.11.2022. this still seems to be the problem. Currently installed version is 4.4.0.72 (Vanha Rauma). This keeps happening ever so often. Just like the connection drops when we have to restart the network subsystem. Any info on when will this be solved?

Edit: This also seem to affect the default email app in a strange way that it won’t display any images, even if a user explicitly asks the app to do so. Granted, in this case one would need to kill the booster-browser --application=jolla-email

As you can see above, nobody else seems to actually have this problem still. (Unless i misunderstand and you want the dnsmasq handling solved).

So without details; don’t expect anything… and maybe, depending on what you find, it’s even worth its own thread.

No, you are correct, I’m also experiencing the very same booster-browser issue. Since I’m not quite sure what the thing is anyway, I’m also unsure as to where to collect the logs. But if you could point me in the right direction, I’m more than willing to collect all the logs necessary.

And it is not dnsmasq/waydroid causing it? No idea what to look at, but always start with journalctl.

Killing the booster-browser fixes the problem, so I’m guessing it’s not related to the dnsmasq. Thanks for the journalctl tip, will look into it, and post my findings here.

1 Like

Have you tried to Restart network ? Settings → Utilities → "Restart network subsystem… " ? Many times it helps with network problems.