Sailfish and ProtonVPN

I tried using ProtonVPN on Sailfish X and it didn’t work. Saw the update for Sailfish 4 and it mentioned better VPN service, however I am still not having any luck. Trying to attach a video here of what is does, anyone else run into this? Not that it matters but I’m using an Xperia 10.

Download the OpenVPN file and use that to create an OpenVPN connection, doesn’t that “just work”? If not, can you share what errors you get (minus personal information) in your journalctl?

Works perfect here.
Do you use the ovpn-file? Have you made sure, that you use the right password for it? ProtonVPN gives its own password for the files… it’s not the one you use to login into your account on the webside!
Good luck!

There was a thread on TJC about ProtonVPN on SailfishOS which may be of help if you wasn’t aware of it yet.

Got these updates from ProtonVPN support concerning the topic:

“ Unfortunately, none of the Android VPN apps are supported. And ProtonVPN is not tested, nor it is supported by ConnMan. All VPN support comes from what ConnMan supports. Kindly note that the application is not officially tested and optimized for custom ROMs, OSes, or Sailfish for example, therefore, we are unable to guarantee that it would work. However, I would like to collect some additional information and forward this to our development team so they can look into this further in the upcoming period and possibly work on optimizing the application for Sailfish.“

Your problem is that perhaps you are trying to use the “app”. Don’t use the “app”. Use the native VPN connection, which has openvpn, which is what ProtonVPN uses. Much better than the “app”, much safer, etc…