Sailfish 4.4 T mobile network denied

Hi All,
I got network denied showing on cellular network on network searching on T mobile on Saifish 4.4 I don’t remember I had this problem on saiflish 4.3/4.2. I didn’t change my previous Data Access Point and MMS configurations. Any ideas to fix this. Thanks.

What makes you think it is not a change on the operator’s side?

I don’t think so, my old xpieria10 is still working. Is there any way to test? I tried the same configuration on 4.4 on Xperia 10ii, but it is not working. I guess it is just not a good OS to use in the US(not official on the jolla site anyway)

What makes you think so?
Denial can most definitely be device specific.
Have you asked your operator?

I don’t think you are helping other than asking me weird questions. I already said, Xperia 10, Xperia 10ii both worked on T-Mobile on 4.2/4.3 and Xperia 10ii upgraded to 4.4 and stops working. What makes you think it is not the OS problem?

You could flash the old image and find out. Or upgrade the 10.

The fact that it is mostly an issue between the operator man modem firmware.

1 Like

I have a couple of questions:

  1. version or
  2. Did you have ‘issues’ with the upgrade.

There are a number of other threads here where people had call/connectivity issues which sometimes had to do with incomplete updates:

Some solutions where a bit involved:

# Make sure repositories point to right version
devel-su ssu re
devel-su ssu rr adaptation-common
devel-su -p pkcon refresh
devel-su -p pkcon install ofono-ril-binder-plugin
# Reboot device
devel-su -p version --dup

Some used @olf 's sfos update


Thank you very much! I almost went out to buy an android phone because of this issue, “denied” message shows under “Select network automatically” for Sony 10 Xperia III, with Sailfish OS (fresh install, not an upgrade).

T-mobile US

I went through the commands on the phone, and a reboot, and then the SIM card showed up as active.

Previously I had to replace the SIM card, and I did this time, yet no avail.

This happened when I try the SIM card on different device.

Thank you

1 Like

The command is not working for me. I upgraded to on my Xperia 10 I, and the t mobile sim works for a day, then got network denied. I tried the command, still can’t connect. Very weird.

Update, I tried another T-Mobile sim and that one works, but the current one doesn’t (it works on my Xperia 1 iv). The oFono logger says slot 1 either not registered or denied. Not sure what is going on. Any ideas? Thanks

You could try to use the other SIM slot to see if that works.

Other sim slot same result, doesn’t work. The sim works one day and I think I try to enable 4g calling, then everything gets denied. Not sure if that is the problem, but other SIM card works

Where are you using T-Mobile that you get Denied? I get this problem in the US on my 10 II, usually after I go somewhere with no signal (like my basement or the dairy department of Trader Joe’s or – worst of all – the middle of my favorite computer store). I’ve never been able to pop a new SIM in my Xperia, power it up, and and get anything but “Denied”. But I have been able sometimes to swap the SIM out of a working device (quickly) into the recently rebooted Xperia and get registered again (until the next dead zone). Not really a complete solution . . .

Wow, this trick works like a charm, thanks. I am using T-Mobile on xperia 10ii, 10iii seems have some API issues on the sailfish os. But this is definitely a bug, this is came a long way already, but it still seems very laggy, and unfinished. I am using it on my secondary phone running some Android apps, really hard not to use Android apps. And the app support is up to android 10, some of the none Google apps can’t run on the sailfish os even it can be installed. I hope they can polish this is more. MMS and group message are other issues.

Hi, I am having trouble receiving/sending MMS, a lot of solutions I have tried, and it doesn’t work. Any configurations that I can use? I am using Mint mobile which is essentially T-Mobile. Thanks.

Update, swapping Sim to another phone that works with the data then switching back, this method is no longer working. only see the signal for 2 sec, then the network is denied. I went back to Xperia 10mk1 which still has 4.1 os, it works perfectly. 4.4/4.5 os, no luck, something definitely changed.