Sailfish 4.0.1.48 and microG

Forgive me, ultimately, before installing any Android app, you need to give these commands:
devel-su
[Type your password]
ln -s / home / defaultuser / home / nemo
and then signature spoofing will work on Kali too?

Thanks for this hint. But…
In what folder do I have to set this link? In / or in /home/nemo ?
Since there are a lot of blanks in the command it is not quite clear what is the name of the link and what is the path.
Is it probably
ln -s /home/defaultuser/home nemo
or something else?
It would be very nice of you if you could tell me the correct command. Thank you very much in advance.
Best regards, Uwe.

Hello,
of course! And sorry for the bad writing!
So, the command I used was:
devel-su
[Type your password]
ln -s /home/defaultuser /home/nemo

Thank you very much! In the meantime I also found out that the command has to be like you said. (I was totally wrong…)
But the problem is that on my SFOS 4.0.1.48 (XA2) there is no defaultuser in folder /home. Is this correct?

After entering of devel-su I’m in folder /home/nemo. Applying the ln-command it creates a sym-link defaultuser in folder /home/nemo which points to /home/nemo.
But after restarting aliendalvik the Signature Spoofing Checker starts up but closes itself after some seconds without any output.
What I’m also wondering about is that Aliendalvik Control (9.3.1-1) looks different from earlier versions (e.g. no settings button)…

Best regards, Uwe.

1 Like

And what, imagine! Well you solved it! :smiley:
I don’t know what to tell you, I’m sorry: in my XA2 (even after several clean installations yes Sailfish) I always found defaultuser in home …
As for Aliendalvik Control, Coderus is working on it together with Patchmanager, still they don’t work on Sailfish 4.

Thanks for answering.
But I’m a bit confused. I have the feeling I did’nt solve it … :frowning:

Is your defaultuser in /home just a (empty?) file or is it a folder?

Best regards, Uwe.

Hello,
I’m sorry but I just don’t remember what was in defaultuser before I created the symbolic link with nemo. :pensive:

As I said above, the proper way to fix the issue is this one:

However, if you are still nemo, and not defaultuser, you are not affected by this particular issue.
Sounds like @uwelabs is nemo? In that case there must be something else not working with the microG install or spoofing settings.

Thank you very much for your hints.
On an earlier SFOS version I used https://together.jolla.com/question/209300/how-to-microg-in-sfos-31/?sort=votes&answer=209744#post-id-209744
to install microG.
I don’t know if this is also valid for 4.0.1.48?

In AlienDalvik-Control (9.3.1-1) on SFOS 4.0.1.48 there is no settings button. So I used
apkd-launcher com.android.settings
to check the settings and all looked good.

Now I found [3.4.0.24] Signature spoofing doesn't work on a freshly flashed xperia 10 plus where Sthocs explains the changing of /usr/sbin/alien-generate-properties.sh in line 133:
export XDG_CONFIG_HOME=/home/$ALIEN_USER/.config
I did this.
But after restarting aliendalvik the Spoofing Checker still vanishes after some seconds without giving any output. So it’s nor clear for me if it works or not.
Best regards, Uwe.

To be sure to understand:

  • You have FakeStore and MicroG Services Core enabled in the enable system package replacement subsection of Android Settings
  • You have the line 133 of alien-generate-properties.sh that has $ALIEN_USER instead of nemo

Then, did you try to simply use the Self Checker of MicroG Settings? I didn’t install Signature Spoofing Checker personally, and it’s enough to work well with apps that need Play Services.

Excuse my late answer.
Yes I have done all that.
But in the Self.-Check not all check boxes are set. For those which are not set it is not possible to set them. (On my wife’s XA2 all checkboxes are set, although I did all the same things as with my XA2.)
I wonder if I shoud uninstall all related microG apks…?.. The microG Service Core app has a version number 2.8… At https://microg.org/download.html there are much newer files. Is it save to use those?
Best regards, Uwe.

I have the same problem.

From the microG app itself the popup to enalbe signature spoofing is coming up but I can’t press “accept”. This is true for alle permissions. I always I have to go trough the jolla settings → Apps → Open Android Settings → Permissions to enable them.
For the signature spoofing it sadly works that way… any help?