Safelite won't start - Sailjail

with Vanha Rauma the password app i’m using (safelite) won’t start anymore.
I think it’s because of Sailjail. Is there any chance to get it running again?

You can disable Sailjail by editing the apps .desktop file. Look at the last 2 lines here: harbour-contrac/harbour-contrac.desktop at master · llewelld/harbour-contrac · GitHub

I have already tried this. Copied the file to sd card. Added the 2 lines (in terminal with vim - horrible). Tried to move back to usr/share/applications/. Got an error message like “filesystem read only”.
I can go to the folder with terminal, but i don’t know how to edit it from there easily!

you can install nano, it’s much more user friendly than vim: pkcon install nano…open file with devel-su nano filename
Edit, then hit crtl+x, then y to save changes, then enter

thx for your reply but the editor is not the problem. I can’t save the changes because of missing permissions.

you can edit it in-place with devel-su vi /usr/share/applications/name.desktop. Press ZZ to save & leave vi.

thx, that’s it! Safe-Lite works.

1 Like