Revolut fails loading since 7.22 version (27 october 2020)

Revolut android app stop working for me since 7.22 (702200707) version on october 27 2020 and microG version. The Revolut app just closes after enter personal code.

Last version that works on SailfishOs is the 7.21 (702100683).

Someone here has this issue too?

1 Like

Revolut app is getting problems again for me after updating to SF 4.4. App loads and enter correctly after login but it fails loading data and it not shows more than a blank page. Anyone having these issues?

1 Like

I’m on 4.4 and using Revolut 8.29.1 works fine. Your microG version seems outdated.

1 Like

4.4 no problems here, using app v8.19.1. MicroG

1 Like

Finally it’s working thanks to answers from people here. Revolut app downloaded from Aurora Store was outdated due to Aurora Store configs Spoof manager itself as Sony Xperia 5 Dual API29 device and Revolut doesn’t updates its API29 app since june 2021. Selecting Xiaomi reloaded_beryllium API30 it downloads an updated Revolut app version that works perfect now.


Revolut blocked a transfer thinking I was senile and got conned (a £175 payment to my neighbour). They say I need the latest version to re-authorise it.
I’ve spoofed as Xiaomi reloaded_beryllium API30 (Edit: don’t do this on 32-bit phones) but Aurora keeps showing me 8.19.1. I’ve relogged, restarted Android, cleared cache & data and downloaded the latest Aurora nightly.
There’s a manual download option but I need the long number without the '.'s

I’m not using the latest one, but 8.29.1 works fine on my X10 II on
Code: 800204139
If you want to try the latest one: 805300050

1 Like

Second one isn’t found. The first is but it downloads and then refuses to install. BTW, if the screen sleeps during downloading, Aurora sometimes won’t even try an installation.

Surely because you use a XA2 (32 bit) and not a X10 II (64 bit). Try from apkpure.

1 Like

I wondered, didn’t know if Android Support was ARM64. And the Xiaomi reloaded_beryllium is an ARM64 phone.

Ugh, APKPure for a banking app. :grimacing:. A transport app from there already tried to steal from me. Downloaded yesterday’s version and it’s at least working. Money transfer approved.

Reverted to Sony pioneer and Aurora still won’t overwrite my APKPure Revolut installation. Same error – might be an inability to overwrite the same version.

Well at least I know where I installed the app from.

So, Aurora Store refuses to upgrade, citing:
INSTALL_FAILED_UPDATE_INCOMPATIBLE: Package com.revolut.revolut signatures do not match previously installed version; ignoring!

I’ve tried adding an installer path a la here and even deleting the key. Aurora Store gives the same error and recreates the key.

Original packages.xml says:

<package name="com.revolut.revolut" codePath="/data/app/com.revolut.revolut-A3ZRuD--C_3tWBbiWFyRaQ==" nativeLibraryPath="/data/app/com.revolut.revolut-A3ZRuD--C_3tWBbiWFyRaQ==/lib" primaryCpuAbi="armeabi-v7a" publicFlags="xxxxxxxxxx" privateFlags="0" ft="xxxxxxxxx" it="xxxxxxxxx" ut="xxxxxxxxxx" version="805300050" userId="xxxxx" isOrphaned="true">
    <sigs count="1" schemeVersion="3">
        <cert index="11" key="xxx" />

Any way of getting off the APKPure bandwagon without uninstalling?

Edit: I tried Xinstaller, an Android app, which seems to patch memory – doesn’t work. Likewise, Lucky Patcher which can rebuild the APKs. Core Mem needs an Xposed bootloader.
The last versions of Revolut on APKPure and Aptoide are malware. :grimacing:

Gave up and reinstalled. Re-authentication isn’t the nightmare it used to be (I heard of people losing £100k because Revolut wouldn’t answer emails).
Now it’s simply an SMS/email 2FA and a selfie (AI checked).

Now I didn’t need to do the installer bypass in packages.xml. That might happen after restarting Android.

Aptoide seems to install the Revolut app without issues.

@pmelas I checked Aptoide. Their latest two versions at least are undoubtedly similarly-sized pieces of malware.

The size of the genuine main APK is about 60MB:

This is from Aurora ie Google’s own PlayStore repository. Whilst there’s some variation on repacked apps, anything smaller than 57MB or bigger than 112MB is incredibly likely to be malware.

Aptoide lists the apps around 57MB but when you download the APK manually, it’s around 20MB.
If you have been compromised, I’d highly recommend cancelling any cards and changing your PIN.
The Help people may also be able to put enhanced security on your account.

There is no reason to use unofficial versions now.

Aurora lists Revolut as 62mb (config.amd64_v8a.apk)

32 vs 64-bit version. And Aptoide seems to be lying about the size of its APKs – but I only checked the web version.

It seems that since the latest update of Revolut (version 9.17), the app will now display a message asking you to set a lock screen pin on your device, and won’t allow you to proceed further.

It seems this feature is not implemented in App Support, therefore making Android apps think no lock screen pin is set even with one set in the Sailfish environment. Hopefully this feature can be implemented soon (see Unable to set lock pin for Android apps requiring it), or Revolut reverts the decision to require lock screen pin.

You can always downgrade the app to version 9.16 which seems to work just fine. In Aurora store, you can use the “Manual download” feature and enter the version string 901600899.

Revolut version 9.16 seems to otherwise work fine on Sailfish. The only feature not working seems to be submission of ID documents for KYC, which fails when the app needs to verify your identity by taking a selfie. “Camera is unavailable. There might be another application using it at the same time” is the error message I am getting. Gave up and used another phone for KYC verification, after which the app can be used on Sailfish.


Thanks Jetten!
I was able to download 9.16, and this works!

I hope Jolla fixes the issue soon, as this is a show-stopper for me!


1 Like

Doing a fresh installation, this version insisted on my upgrading. In spite of my concerns, there was no demand for a lock screen pin and the latest version went through the selfie check and seems to work fine.

Note, I am very p*ssed-off with Revolut who literally blocked access to my money for 1-2 weeks after I reported my XA2 lost. They blocked my bank card in spite of my telling them not to and it being at no risk (unless CVV or keys are stupidly stored in the app). It seems lots of people have similar stories. To restore my access, I had to use a friend’s phone and change to her phone number on my account… in order to change my Revolut passcode. BTW, you have to tell them to do the latter – they tell you you need a new SIM. They insisted on vetting my card after that.
I have reported this to the British FCA, the EU’s EBA and my old MP so far. They also paid an employee an estimated £200 to fob me off with Metal (upgraded account) for 4 months. Never ever tell a fintech bank you’ve lost your phone.