Restore cutes-js?

cutes-js has been removed from SFOS 3.3.0.16 rokua, for obscure reasons. As a result, some apps (for instance Schturman’s “quick file backup”, very useful) are no longer installable (unless you still have components from older OS releases). Is there any way to restore it after a fresh OS installation?

Jolla does not care (and agreed cannot verify) about third party (i.e. JOLLA STORE as well as OpenRepos) compatibility. But they could be a bit more verbous in advance that some packages will get removed and why! But…

In factbyou can download these packages from an olderbrelease repository but it is a hassle to find the link as these repos are still not open browsable to the community! So you may find outbthe link to the current repo, change it accordingly to the older one, find out the name of package and esoecially the versiin number in that older release by looking through the version announcements, modify the link, download andbinstall. A HASSLE!
Or ask in the community to have someone with older release to download it for you. But keep in mind this might be only a temporary solution as it might break in future…

1 Like

For those having a second device where missing components are still present (my beloved old Jolla phone for example), there is maybe a solution. Grab and copy this from the old to the new device:

/usr/bin/cutes
/usr/lib/libcutes-qt5.so.0 and libcutes-qt5.so.0.9.13 and libicutest.so.63 and libicutest.so.63.1
/usr/lib/qt5/cutes/qt/libcutes-core.so
/usr/lib/qt5/qml/mer/Cutes/libcutesqml.so and qmldir
/usr/share/cutes/ everything found here (33 elements)

EDIT - doesn’t work. Cutes still considered uninstalled. Sigh.

The project page is probably this: https://git.sailfishos.org/mer-core-attic/cutes
If someone can explain how to get it back, thanks in advance.

Does this help? cutes-json-js versions and pkcon

Sadly it doesn’t help, as Jolla deleted the cutes-js package or made it not accessible in Rokua sfos release.

on second device where the package is available try:
pkcon download ~ cutes

this should download the package to /home/nemo folder

I did. But as both devices have been ‘upgraded’ to Rokua, the required repository is no longer accessible .

You could compile it on OBS or SDK. I presume it does compile against the new SFOS version.

I wish I could. Maybe this is a good opportunity to learn that, provided there is a clear howto for dummies…

I have SDK with 3.2.1.20 so I tried to download package cutes-js over ssh but it gives me error:
Fatal error: Insufficient space in download directory ‘/var/cache/pk-zypp-cache/packages/jolla’.

according to pkcon search cutes, these packages are in repo

|Available   |cutes-coffee-script-0.9.2.3-1.1.17.jolla.noarch (jolla)     |CoffeeScript compiler for cutes|
|Available   |cutes-js-0.9.2.3-1.1.17.jolla.noarch (jolla)                |Javascript libraries for cutes|
|Available   |cutes-js-tests-0.9.2.3-1.1.17.jolla.noarch (jolla)          |Tests for cutes-js|
|Available   |cutes-json-js-0.9.2.3-1.1.17.jolla.noarch (jolla)           |Canonical javascript json parser|
|Available   |cutes-narwhal-0.9.2.3-1.1.17.jolla.noarch (jolla)           |Narwhal javascript library|
|Available   |cutes-qt5-0.9.13-1.3.1.jolla.i486 (jolla)                   |QtScript environment and "interpreter"|
|Available   |cutes-qt5-debuginfo-0.9.13-1.3.1.jolla.i486 (jolla)         |Debug information for package cutes-qt5|
|Available   |cutes-qt5-debugsource-0.9.13-1.3.1.jolla.i486 (jolla)       |Debug sources for package cutes-qt5|
|Available   |cutes-qt5-devel-0.9.13-1.3.1.jolla.i486 (jolla)             |Development support for cutes extensions|
|Available   |cutes-qt5-doc-0.9.13-1.3.1.jolla.i486 (jolla)               |Documentation for cutes-qt5|
|Available   |cutes-qt5-tests-0.9.13-1.3.1.jolla.i486 (jolla)             |Tests for cutes|
|Available   |cutes-underscore-js-0.9.2.3-1.1.17.jolla.noarch (jolla)     |Underscore.js library|
1 Like

Thanks. So, should I reflash my Xperia X to 3.2.1.20 (I kept the images) to gain access to the required repo and download cutes-js plus dependencies, then back it up then reflash (or ‘upgrade’) to 3.3.0.16 and reinstall cutes-js from the back up?
I wonder if Jolla realizes the inconvenience of their weird decision to remove a small component without any consideration for backwards compatibility.

https://releases.jolla.com/releases/3.2.1.20/jolla/armv7hl/mw/noarch/cutes-coffee-script-0.9.2.3-1.1.28.jolla.noarch.rpm
https://releases.jolla.com/releases/3.2.1.20/jolla/armv7hl/mw/noarch/cutes-js-0.9.2.3-1.1.28.jolla.noarch.rpm
https://releases.jolla.com/releases/3.2.1.20/jolla/armv7hl/mw/noarch/cutes-json-js-0.9.2.3-1.1.28.jolla.noarch.rpm
https://releases.jolla.com/releases/3.2.1.20/jolla/armv7hl/mw/noarch/cutes-narwhal-0.9.2.3-1.1.28.jolla.noarch.rpm
https://releases.jolla.com/releases/3.2.1.20/jolla/armv7hl/mw/armv7hl/cutes-qt5-0.9.13-1.3.1.jolla.armv7hl.rpm
https://releases.jolla.com/releases/3.2.1.20/jolla/armv7hl/mw/noarch/cutes-underscore-js-0.9.2.3-1.1.28.jolla.noarch.rpm

2 Likes

GREAT! Dependent apps (a.o. Schturman’s precious QuickFileBackup) now working again. Just make sure to install cutes components in the proper order i.e. main cutes-js after all other ones are installed. Problem solved, thanks a lot.

PS: I hope Jolla will stop removing OS components without paying sufficient attention, and restore cutes-js in next releases.

you can pkcon install-local *.rpm and it will install all rpms in correct order

1 Like