[Resolved] Jolla-mediaplayer not scanning for music

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (Jolla1, Tablet, XA2,…): xperia 10 dual sim
UI LANGUAGE: english
REGRESSION: (compared to previous public release: Yes, No, ?): ?


jolla-mediaplayer does not scan for music. It detects neither data stored in nemos home nor on the sdcard in the Music folder.



  1. Start jolla-mediaplayer
  2. wait


jolla-mediaplayer should start scanning my music collection and display titles accordingly.


it shows 0 titles, 0 artists and 0 albums


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Sometimes, indexing media content can take some time. I have only around 8 albums on my device, but tracker still takes a good 30 seconds to index and display what it finds. However, as you’ve now experienced, Tracker doesn’t always kick in when it should. Rebooting the device should cause Tracker to get busy, if not, you can nudge it in terminal or with Sailfish Utilities found in the Jolla Store.

Terminal command:

tracker reset -e

If you choose Sailfish Utilities - you need the last option in the list.

Thanks but I already tried that. No improvement. I even had the phone laying around over night with mediaplayer active…

Well, this is weird… it just needed another kick… tried the exact same again and suddenly it has started indexing :man_shrugging:. Thanks. This is resolved for me now.

Ah, good, glad you got sorted.

Fixed now, maybe triggering it from utilities solved it…

Didn’t have that problem with the update to, but now with the new version. Resetting does not do anything at all.

With 3.4.024 it works, but it takes ages to index.

Yes, I had to learn this too. Took roundabout two hours to index 1000 Files.

For 15k files ~30min, guess it also depends on the speed of your sdcard.