Request: Minimum volume a lot quieter

I’m not sure if this is the right subforum to post this request.

I would like to request a better range of volume settings in general for Sailfish, no matter if you listen to music, phone at ear/headseat/loudspeaker, the minimum volume is still extremely loud. Yesterday i did phone with somebody with the loudspeakers and even if the person did whisper it came out so loud on the speakers, it was really unpleasant. The volume was on minimum ofc.
Please make it possible to set the volume for phonecalls and other sounds a lot more quieter.

16 Likes

I cannot even imagine my phone becoming unpleasantly loud using the loudspeakers – I always have to have them directly near my ears to distinguish their output from environmental noise. So this must be device specific. Would you please tell the hardware that you use?

I agree, for Notifications, viewing videos etc. the minvolume sometimes is too loud.

Xperia 10 Dual, | Sailfish 3.3.0.16

Yes. Another begger here.
And this was like that on Jolla C as well, now on XA2 (and iirc it was already like that on Jolla1).
In quiet atmosphere this minimum volume is just too loud. Really too loud. I always have to press my finger on the loudspeaker.

I have both problems, sometimes its way too loud, but other times it could be much louder.

3 Likes

I too am experiencing the volume being unreasonable, either high or low. My device is an Xperia 10+ running Sailfish X 3.3.0.16.

With the speakers, the output seems to be fine, but with Bluetooth, the volume is way too low for media consumption and far too loud for phone calls.

I came up with a simple workaround in this thread for the Bluetooth audio for music playback, but when taking a call today, I had to switch to just using the phone itself, as the headset was unusable at minimum volume due to it being way too loud. (I understand my volume boost made this problem worse than it would have been, but I think even at normal volume, it would still have been twice as loud as it needed to be.)

While I think it makes sense to ideally keep all devices at the same volume level, it seems to not be universal depending on device or application used, and therefore some way to adjust the volume up or down for certain use cases would be a welcome change from my perspective.

1 Like

A quick workaround is to open the terminal and run pactl list sinks short. It should give an output like this:

0       sink.primary    module-droid-card.c     s16le 2ch 48000Hz       SUSPENDED
1       sink.deep_buffer        module-droid-card.c     s16le 2ch 48000Hz       RUNNING
2       sink.null       module-null-sink.c      s16le 2ch 48000Hz       SUSPENDED

Check which output is marked running. Next run pactl set-sink-volume <no.> 50%, where <no.> is the
number you just got. You can obviously change the 50% to whatever percentage you desire, as long as you make sure to include the percent sign. This will decrease your maximum volume to the percentage you’ve entered and you will still be able to change the volume with your volume keys. By entering an percentage larger than 100% you can actually increase your volume, although it will come with the inevitable distortion.

Changes will be lost after a reboot (or pulseaudio restart). You can also restore the full volume by running pactl set-sink-volume <no.> 100%.

Maybe I should integrate this into audio-output-chooser.

1 Like

I am unable to edit my last post, so am just replying to part of what I said in that post to make a correction.

I have only ever been able to reproduce the problem where the minimum volume is way too loud when I was using my 200% sink volume boost used primarily during media consumption. When I had the sink volume at its normal level of 100%, the volume has always been perfect during calls. I just wanted to make a correction to what I said, and I suspect the problem I saw was solely caused by me, and may totally different than what the original poster and others are experiencing. Now I just boost the sink volume when needed using the Situations app (which runs a bash script), and drop it back down to normal during phone calls (again with Situations and a script). I posted more information in a follow-up to the link mentioned in my previous post above.

Same problem here with XA2, for calls loudspeaker is too loud and there is also the bug that when enabled, it starts high and to reset it to the lowest setting you have to adjust it to higher and back to lowest.

1 Like