[Release notes] Verla 4.2.0

Upgrading from 4.1.0.24 to 4.2.0.21 on my 10 II took ~890 MB and I’ve observed the same warning “remove the following packages because they may cause problems during the upgrade: $list_of_many_system_packages>”.

Other observations regarding the update process:

  • Very low screen brightness after reboot (when entering cryptsetup PIN and while displaying progress of the upgrade)
  • GUI upgrade seemed to hang at 0% after the reboot. Finally, I did a manual upgrade (ssu re 4.2.0.21, version --dup, reboot) because the progress bar was barely visible anyway (see above)

and some first notes regarding the update itself:

  • Sticky mode of app grid only works on the first page - the behaviour for the second page of app icons is still paging-only (just like in the previous version)
  • Predictive text input only works after installing from harbour and rebooting again

Same here …

Thank you Jolla for the Update!
Installed it right now and updated from 4.2.0.19 to 4.2.0.21 .
Download size was 40 MB.
Have to report that after the complete download, update and restart, I came to enter the encryption code, then it tried to boot, but doesn’t work but rebooted after a short time.

But after the second reboot, it runs fine, without visible problems. Storeman asked again for access to something, but only one time.
Phone seems ot work fine, including browser, LLs player, AllRadio, File manager, Books, Quanto Fa, Wunderfitz, Unplayer, Camera, Pure Maps. (tested)

Phone works fine!

edit: saw right now that browser is on (felt) double or triple speed! Thanks again Jolla!

Seems to be the solution. Could not reproduce crash yet since deactivating all alarms (and activating again afterwards). Thanks a lot!

today I successfully logged into the wifi of Deutsche Bahn ICE. I missed to hit the notification, so I opened the browser and entered http://neverssl.com as the url, which was redirected to the landing page. I could tick the required box and press the accept button, which wasn’t the case in previous versions.

Actually I’m on 4.2.0.21

6 Likes

yes, captive portals are working now in my case (hlb - ger, clicked notification, button worked now)

I still need to restart android several times a day because its permanently loosing connection with weak wifi or cellular. However, the browser was affected in the previous EA as well and is not anymore with .21

Edit: it just happened again. browser could not connect. switching into and from flightmode fixes it

1 Like

I think the phone remembers the brightness setting from last session. Maybe this value was set to the lowest in the update process.

Did you check the brightness setting in the upper menu? Is it set to lowest? If you set it brighter, does low brightness persist at next unlock or reboot of device? Or does the device now remember the last brightness setting?

I always set the brightness to the lowest value - but the screen is was much brighter when I startet the update. Therefore I do not believe that the phone remembered the brightness level.

1 Like

After yesterday’s update to 4.2.0.21, I experienced loss of telephone audio at least twice during the call. Audio did not get restored in next call fired immediately after previous call (call again). It restored after 1/2 hour without restart.

I too experienced low brightness when entering decrypting password and on upgrade progress screen, almost as dark as no background light (I was in a lit environment, so I couldn’t verify). I don’t think it’s related to 4.2.0.19, as I saw it when I upgrade to that version as well.

i got the same problem on xa2, edge swiping is more difficult now. The protective case i use makes edge swipe almost impossible. I have to either rotate the phone or switch off the screen which none of these is practical.

4 Likes

i experience this as well. i even renove the protector a bit sometimes to make it work, but that leads to unwanted touch actions 50% of the time

2 Likes

The same here on Xperia 10 II. Successful edge swiping is a stroke of luck.

2 Likes

Our current goal is to make 4 public releases per year, so quarterly releases. 4.2.0 is the 2nd one this year, so badly delayed. We will try to catch up with the schedule. We used to make monthly releases in the past but that did not work well.

14 Likes

[EDIT] I’ve just noticed that the settings for automatic backup in the cloud were lost after the upgrade to 4.2

I had disabled storage authorization to onedrive ! With the authorization, the settings are back in the settings app.

My settings (Nextcloud) are still there, but the backup does not seem to be run by schedule.

1 Like

Same issue on my Xperia XA2 too, swipe from the edges gets on my nerves too. The most of the time it doesn’t work as before :-/

EDIT: upgrade to the newest 4.2.0.21 version looks that help. Swipe is now much better…

Unfortunately I cannot confirm any enhancement with swipe from the edge on 4.2.0.21 it’s still rather hard to swipe for task switch instead to issue an unwanted in-app-swipe. [This is for my XA2+ on 4.2.0.21]

1 Like

swiping works but the exact ‘timing’ or how exactly to perform the fingers movement is much more critical than in previous SFOS version.

Jolla, please make a little fine tuning on this!

Q: where are the parameters stored? edit: in what config file, so that I can play around a little with ist.

I would like to see information like this as a blog post (or a separate announcement here in the forums), even if it’s just a short piece like that. News of decisions like these should be made more visible (rather than as a comment in a huge thread about something loosely related to it).

Btw; the blogpost about 4.2.0 calls it “a new Sailfish release – the third one this year” :slight_smile:

1 Like